summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/cantor')
-rw-r--r--kde-base/cantor/ChangeLog7
-rw-r--r--kde-base/cantor/cantor-4.8.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/cantor/ChangeLog b/kde-base/cantor/ChangeLog
index 13b58f3f2e08..6476af5758f2 100644
--- a/kde-base/cantor/ChangeLog
+++ b/kde-base/cantor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/cantor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.64 2012/04/18 19:30:34 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.65 2012/05/03 20:08:10 johu Exp $
+
+*cantor-4.8.3 (03 May 2012)
+
+ 03 May 2012; Johannes Huber <johu@gentoo.org> +cantor-4.8.3.ebuild:
+ Version bump KDE SC 4.8.3
18 Apr 2012; Markus Meier <maekke@gentoo.org> cantor-4.8.1.ebuild:
x86 stable, bug #409403
diff --git a/kde-base/cantor/cantor-4.8.3.ebuild b/kde-base/cantor/cantor-4.8.3.ebuild
new file mode 100644
index 000000000000..3dcab4cc9bec
--- /dev/null
+++ b/kde-base/cantor/cantor-4.8.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.8.3.ebuild,v 1.1 2012/05/03 20:08:10 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="analitza debug ps +R"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+RDEPEND="
+ analitza? ( $(add_kdebase_dep analitza) )
+ ps? ( app-text/libspectre )
+ R? ( dev-lang/R )
+"
+DEPEND="${RDEPEND}
+ >=dev-cpp/eigen-2.0.3:2
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with analitza)
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with R)
+ )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use R; then
+ echo
+ ewarn "You have decided to build ${PN} with no backend."
+ ewarn "To have this application functional, please do one of below:"
+ ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'R' USE flag enabled"
+ ewarn " # emerge -vaDu sci-mathematics/maxima"
+ echo
+ fi
+}