summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/cantor/cantor-4.6.1.ebuild')
-rw-r--r--kde-base/cantor/cantor-4.6.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-base/cantor/cantor-4.6.1.ebuild b/kde-base/cantor/cantor-4.6.1.ebuild
new file mode 100644
index 000000000000..825a06ca9c98
--- /dev/null
+++ b/kde-base/cantor/cantor-4.6.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.6.1.ebuild,v 1.1 2011/03/04 18:00:21 alexxy Exp $
+
+EAPI=3
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug ps +R"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+RDEPEND="
+ ps? ( app-text/libspectre )
+ R? ( dev-lang/R )
+"
+DEPEND="${RDEPEND}
+ >=dev-cpp/eigen-2.0.3:2
+"
+
+RESTRICT=test
+
+src_configure() {
+ mycmakeargs+="
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with R)
+ "
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! use R; then
+ echo
+ ewarn "You have decided to build ${PN} with no backend."
+ ewarn "To have this application functional, please do one of below:"
+ ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'R' USE flag enabled"
+ ewarn " # emerge -vaDu sci-mathematics/maxima"
+ echo
+ fi
+}