summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/arts')
-rw-r--r--kde-base/arts/arts-1.3.2-r1.ebuild10
-rw-r--r--kde-base/arts/arts-1.3.2.ebuild10
-rw-r--r--kde-base/arts/files/arts-1.2.3-buffer.patch27
-rw-r--r--kde-base/arts/files/arts-vorbis-fix.dif23
4 files changed, 2 insertions, 68 deletions
diff --git a/kde-base/arts/arts-1.3.2-r1.ebuild b/kde-base/arts/arts-1.3.2-r1.ebuild
index e44c2d13fb30..0ce77e8b4281 100644
--- a/kde-base/arts/arts-1.3.2-r1.ebuild
+++ b/kde-base/arts/arts-1.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.3.2-r1.ebuild,v 1.9 2005/07/25 15:29:11 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.3.2-r1.ebuild,v 1.10 2005/10/13 13:29:17 greg_g Exp $
inherit kde flag-o-matic eutils
set-kdedir 3.3
@@ -23,11 +23,6 @@ DEPEND="alsa? ( media-libs/alsa-lib virtual/alsa )
>=dev-libs/glib-2
$(qt_min_version 3.3)"
-# patch to configure.in.in that makes the vorbis, libmad deps optional
-# has no version number in its filename because it's the same for all
-# arts versions - the patched file hasn't changed in a year's time
-# PATCHES="$FILESDIR/optional-deps.diff"
-
src_unpack() {
kde_src_unpack
epatch ${FILESDIR}/1.3.0-jack-configure.in.in.patch
@@ -42,9 +37,6 @@ src_unpack() {
# rm -f $S/configure
cd ${S} && make -f admin/Makefile.common
- # use amd64 && epatch ${FILESDIR}/arts-${PV}-buffer.patch
- # this patch fixes the high cpu usage of mp3 and vorbis
- # epatch ${FILESDIR}/arts-vorbis-fix.dif
}
src_compile() {
diff --git a/kde-base/arts/arts-1.3.2.ebuild b/kde-base/arts/arts-1.3.2.ebuild
index 50ce7fb0ea00..51b2e2b7d9f0 100644
--- a/kde-base/arts/arts-1.3.2.ebuild
+++ b/kde-base/arts/arts-1.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.3.2.ebuild,v 1.15 2005/07/25 15:29:11 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.3.2.ebuild,v 1.16 2005/10/13 13:29:17 greg_g Exp $
inherit kde flag-o-matic eutils
set-kdedir 3.3
@@ -24,11 +24,6 @@ DEPEND="alsa? ( media-libs/alsa-lib virtual/alsa )
$(qt_min_version 3.3)
>=sys-apps/portage-2.0.49-r8"
-# patch to configure.in.in that makes the vorbis, libmad deps optional
-# has no version number in its filename because it's the same for all
-# arts versions - the patched file hasn't changed in a year's time
-# PATCHES="$FILESDIR/optional-deps.diff"
-
src_unpack() {
kde_src_unpack
epatch ${FILESDIR}/1.3.0-jack-configure.in.in.patch
@@ -43,9 +38,6 @@ src_unpack() {
# rm -f $S/configure
cd ${S} && make -f admin/Makefile.common
- # use amd64 && epatch ${FILESDIR}/arts-${PV}-buffer.patch
- # this patch fixes the high cpu usage of mp3 and vorbis
- # epatch ${FILESDIR}/arts-vorbis-fix.dif
}
src_compile() {
diff --git a/kde-base/arts/files/arts-1.2.3-buffer.patch b/kde-base/arts/files/arts-1.2.3-buffer.patch
deleted file mode 100644
index b8bb4a94ec9f..000000000000
--- a/kde-base/arts/files/arts-1.2.3-buffer.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- mcop/buffer.cc.orig 2004-03-24 14:51:23.586055192 +0100
-+++ mcop/buffer.cc 2004-03-24 14:56:14.054897216 +0100
-@@ -87,9 +87,8 @@
- void Buffer::writeFloat(float f) {
- // FIXME: on some machines this may fail badly (there is explicit
- // float marshalling and demarshalling code in mico/orb/util.cc)
--
-- long *f_as_long = (long *)&f;
-- writeLong(*f_as_long);
-+ union { float f; long l; } u = {f};
-+ writeLong(u.l);
- }
-
- void Buffer::writeFloatSeq(const std::vector<float>& seq) {
-@@ -252,9 +251,10 @@
- float Buffer::readFloat()
- {
- // FIXME: see writeFloat()
-- long f_as_long = readLong();
-+ union {float f; long l; } u;
-+ u.l = readLong();
-
-- if(!_readError) return *(float *)&f_as_long;
-+ if(!_readError) return u.f;
- return 0.0;
- }
-
diff --git a/kde-base/arts/files/arts-vorbis-fix.dif b/kde-base/arts/files/arts-vorbis-fix.dif
deleted file mode 100644
index 344b5a75e75a..000000000000
--- a/kde-base/arts/files/arts-vorbis-fix.dif
+++ /dev/null
@@ -1,23 +0,0 @@
---- flow/gsl/gslloader.c-dist 2004-03-31 21:23:54.807890367 +0200
-+++ flow/gsl/gslloader.c 2004-03-31 21:29:51.380200687 +0200
-@@ -313,7 +313,8 @@ gsl_wave_chunk_create (GslWaveDsc *wav
-
- /* FIXME: we essentially create a dcache for each wchunk here ;( */
-
-- dcache = gsl_data_cache_from_dhandle (dhandle, gsl_get_config ()->wave_chunk_padding * wave_dsc->n_channels);
-+ /* dcache = gsl_data_cache_from_dhandle (dhandle, gsl_get_config ()->wave_chunk_padding * wave_dsc->n_channels); */
-+ dcache = gsl_data_cache_from_dhandle (dhandle, 0); /* FIXME: padding is bad for vorbis... */
- gsl_data_handle_unref (dhandle);
- if (!dcache)
- return NULL;
---- flow/gsl/gslcommon.c-dist 2004-03-31 21:18:45.247935730 +0200
-+++ flow/gsl/gslcommon.c 2004-03-31 21:29:24.103373480 +0200
-@@ -1585,7 +1585,7 @@ gsl_init (const GslConfigValue values[],
- 1, /* n_processors */
- 2, /* wave_chunk_padding */
- 4, /* wave_chunk_big_pad */
-- 512, /* dcache_block_size */
-+ 8192, /* dcache_block_size */
- 1024 * 1024, /* dcache_cache_memory */
- 69, /* midi_kammer_note */
- 440, /* kammer_freq */