summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/ark/ark-4.7.1.ebuild')
-rw-r--r--kde-base/ark/ark-4.7.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/kde-base/ark/ark-4.7.1.ebuild b/kde-base/ark/ark-4.7.1.ebuild
new file mode 100644
index 000000000000..dbff26ff926e
--- /dev/null
+++ b/kde-base/ark/ark-4.7.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.7.1.ebuild,v 1.1 2011/09/07 20:13:49 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdeutils"
+ kde_eclass="kde4-meta"
+fi
+inherit ${kde_eclass}
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug lzma"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ sys-libs/zlib
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+ lzma? ( app-arch/xz-utils )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ )
+ ${kde_eclass}_src_configure
+}
+
+pkg_postinst() {
+ ${kde_eclass}_pkg_postinst
+ elog "For creating rar archives, install app-arch/rar"
+}