summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-libs')
-rw-r--r--gnustep-libs/rigs/ChangeLog11
-rw-r--r--gnustep-libs/rigs/files/digest-rigs-0.2.2.20050714-r1 (renamed from gnustep-libs/rigs/files/digest-rigs-0.2.2.20050714)0
-rw-r--r--gnustep-libs/rigs/rigs-0.2.2.20050714-r1.ebuild61
-rw-r--r--gnustep-libs/rigs/rigs-0.2.2.20050714.ebuild80
4 files changed, 70 insertions, 82 deletions
diff --git a/gnustep-libs/rigs/ChangeLog b/gnustep-libs/rigs/ChangeLog
index 434e4130dd32..c946b8824e8c 100644
--- a/gnustep-libs/rigs/ChangeLog
+++ b/gnustep-libs/rigs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnustep-libs/rigs
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/rigs/ChangeLog,v 1.4 2006/12/31 10:18:05 grobian Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/rigs/ChangeLog,v 1.5 2007/09/11 11:31:06 voyageur Exp $
+
+*rigs-0.2.2.20050714-r1 (11 Sep 2007)
+
+ 11 Sep 2007; Bernard Cafarelli <voyageur@gentoo.org>
+ -rigs-0.2.2.20050714.ebuild, +rigs-0.2.2.20050714-r1.ebuild:
+ Port to new GNUstep eclasses
+ Fixes bug #170467
31 Dec 2006; Fabian Groffen <grobian@gentoo.org>
+files/rigs-0.2.2.20050714-compile.patch, rigs-0.2.2.20050714.ebuild:
diff --git a/gnustep-libs/rigs/files/digest-rigs-0.2.2.20050714 b/gnustep-libs/rigs/files/digest-rigs-0.2.2.20050714-r1
index 485c1bc4a8e1..485c1bc4a8e1 100644
--- a/gnustep-libs/rigs/files/digest-rigs-0.2.2.20050714
+++ b/gnustep-libs/rigs/files/digest-rigs-0.2.2.20050714-r1
diff --git a/gnustep-libs/rigs/rigs-0.2.2.20050714-r1.ebuild b/gnustep-libs/rigs/rigs-0.2.2.20050714-r1.ebuild
new file mode 100644
index 000000000000..d414c99fff72
--- /dev/null
+++ b/gnustep-libs/rigs/rigs-0.2.2.20050714-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/rigs/rigs-0.2.2.20050714-r1.ebuild,v 1.1 2007/09/11 11:31:06 voyageur Exp $
+
+inherit gnustep-2
+
+DESCRIPTION="Ruby Interface for GNUstep."
+HOMEPAGE="http://www.gnustep.org/experience/RIGS.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86 ~ppc"
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+
+DEPEND="dev-lang/ruby"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/${P}-install-rb.patch
+ epatch "${FILESDIR}"/${P}-compile.patch
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ # install shared library
+ RUBY_SITE_ARCH_DIR=$(ruby -rrbconfig -e 'print Config::CONFIG["sitearchdir"]')
+ dodir ${RUBY_SITE_ARCH_DIR}
+ cd ${S}/Source/obj
+ if use debug; then
+ dosym \
+ ${GNUSTEP_SYSTEM_LIBRARIES}/librigs_d.so \
+ ${RUBY_SITE_ARCH_DIR}/librigs.so
+ else
+ dosym \
+ ${GNUSTEP_SYSTEM_LIBRARIES}/librigs.so \
+ ${RUBY_SITE_ARCH_DIR}/librigs.so
+ fi
+
+ # Install .rb files
+ RUBY_SITE_LIB_DIR=$(ruby -rrbconfig -e 'print Config::CONFIG["sitelibdir"]')
+ dodir ${RUBY_SITE_LIB_DIR}/rigs
+ cd ${S}/Ruby
+ cp -f rigs.rb Foundation.rb AppKit.rb ${D}/${RUBY_SITE_LIB_DIR}
+ cd ${S}/Ruby/rigs
+ RB_FILES=$(ls *.rb -1 --color=never)
+ cp -f ${RB_FILES} ${D}/${RUBY_SITE_LIB_DIR}/rigs
+
+ # install examples
+ if use doc; then
+ cd ${S}
+ dodir ${GNUSTEP_SYSTEM_DOC}/RIGS
+ cp -pPR Examples ${D}/${GNUSTEP_SYSTEM_DOC}/RIGS
+ rm -Rf \
+ ${D}/${GNUSTEP_SYSTEM_DOC}/RIGS/Examples/CVS \
+ ${D}/${GNUSTEP_SYSTEM_DOC}/RIGS/Examples/Base/CVS \
+ ${D}/${GNUSTEP_SYSTEM_DOC}/RIGS/Examples/Gui/CVS
+ fi
+}
diff --git a/gnustep-libs/rigs/rigs-0.2.2.20050714.ebuild b/gnustep-libs/rigs/rigs-0.2.2.20050714.ebuild
deleted file mode 100644
index 24032a36155e..000000000000
--- a/gnustep-libs/rigs/rigs-0.2.2.20050714.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/rigs/rigs-0.2.2.20050714.ebuild,v 1.4 2006/12/31 10:18:05 grobian Exp $
-
-inherit gnustep
-
-DESCRIPTION="Ruby Interface for GNUstep."
-HOMEPAGE="http://www.gnustep.org/experience/RIGS.html"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-KEYWORDS="~x86 ~ppc"
-LICENSE="LGPL-2.1 GPL-2"
-SLOT="0"
-
-IUSE="doc"
-DEPEND="${GS_DEPEND}
- dev-lang/ruby"
-RDEPEND="${GS_RDEPEND}
- dev-lang/ruby"
-
-egnustep_install_domain "Local"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch "${FILESDIR}"/${P}-install-rb.patch
- epatch "${FILESDIR}"/${P}-compile.patch
-}
-
-src_install() {
- gnustep_src_install
-
- # install shared library
- RUBY_SITE_ARCH_DIR=$(ruby -rrbconfig -e 'print Config::CONFIG["sitearchdir"]')
- dodir ${RUBY_SITE_ARCH_DIR}
- cd ${S}/Source/obj
- if use debug; then
- #dolib librigs_d.so
- if [ "${GNUSTEP_FLATTENED}" ]; then
- dosym \
- ${GNUSTEP_LOCAL_ROOT}/Library/Libraries/librigs_d.so \
- ${RUBY_SITE_ARCH_DIR}/librigs.so
- else
- dosym \
- ${GNUSTEP_LOCAL_ROOT}/Library/Libraries/${GNUSTEP_HOST_CPU}/${GNUSTEP_HOST_OS}/${LIBRARY_COMBO}/librigs_d.so \
- ${RUBY_SITE_ARCH_DIR}/librigs.so
- fi
- else
- #dolib librigs.so
- if [ "${GNUSTEP_FLATTENED}" ]; then
- dosym \
- ${GNUSTEP_LOCAL_ROOT}/Library/Libraries/librigs.so \
- ${RUBY_SITE_ARCH_DIR}/librigs.so
- else
- dosym \
- ${GNUSTEP_LOCAL_ROOT}/Library/Libraries/${GNUSTEP_HOST_CPU}/${GNUSTEP_HOST_OS}/${LIBRARY_COMBO}/librigs.so \
- ${RUBY_SITE_ARCH_DIR}/librigs.so
- fi
- fi
-
- # Install .rb files
- RUBY_SITE_LIB_DIR=$(ruby -rrbconfig -e 'print Config::CONFIG["sitelibdir"]')
- dodir ${RUBY_SITE_LIB_DIR}/rigs
- cd ${S}/Ruby
- cp -f rigs.rb Foundation.rb AppKit.rb ${D}/${RUBY_SITE_LIB_DIR}
- cd ${S}/Ruby/rigs
- RB_FILES=$(ls *.rb -1 --color=never)
- cp -f ${RB_FILES} ${D}/${RUBY_SITE_LIB_DIR}/rigs
-
- # install examples
- if use doc; then
- cd ${S}
- dodir ${GNUSTEP_LOCAL_ROOT}/Library/Documentation/RIGS
- cp -pPR Examples ${D}/${GNUSTEP_LOCAL_ROOT}/Library/Documentation/RIGS
- rm -Rf \
- ${D}/${GNUSTEP_LOCAL_ROOT}/Library/Documentation/RIGS/Examples/CVS \
- ${D}/${GNUSTEP_LOCAL_ROOT}/Library/Documentation/RIGS/Examples/Base/CVS \
- ${D}/${GNUSTEP_LOCAL_ROOT}/Library/Documentation/RIGS/Examples/Gui/CVS
- fi
-}