summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/librsvg/librsvg-2.14.3.ebuild')
-rw-r--r--gnome-base/librsvg/librsvg-2.14.3.ebuild49
1 files changed, 28 insertions, 21 deletions
diff --git a/gnome-base/librsvg/librsvg-2.14.3.ebuild b/gnome-base/librsvg/librsvg-2.14.3.ebuild
index 2b3625d813e4..f3ffa3a3fb30 100644
--- a/gnome-base/librsvg/librsvg-2.14.3.ebuild
+++ b/gnome-base/librsvg/librsvg-2.14.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.14.3.ebuild,v 1.1 2006/05/02 16:15:41 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.14.3.ebuild,v 1.2 2006/06/29 22:38:48 foser Exp $
inherit eutils multilib gnome2 autotools
@@ -13,40 +13,47 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc gnome zlib"
RDEPEND=">=media-libs/fontconfig-1.0.1
- >=x11-libs/gtk+-2
- >=dev-libs/glib-2
- >=media-libs/libart_lgpl-2.3.10
- >=dev-libs/libxml2-2.4.7
- >=x11-libs/pango-1.2
- >=x11-libs/cairo-1.0.2
- >=dev-libs/popt-1.5
- >=dev-libs/libcroco-0.6.1
- media-libs/freetype
- zlib? ( >=gnome-extra/libgsf-1.6 )
- gnome? ( >=gnome-base/gnome-vfs-2 )"
+ >=x11-libs/gtk+-2
+ >=dev-libs/glib-2
+ >=dev-libs/libxml2-2.4.7
+ >=x11-libs/pango-1.2
+ >=x11-libs/cairo-1.0.2
+ >=dev-libs/popt-1.5
+ >=dev-libs/libcroco-0.6.1
+ >=media-libs/freetype-2
+ zlib? ( >=gnome-extra/libgsf-1.6 )
+ gnome? ( >=gnome-base/gnome-vfs-2 )"
# libgnomeprint dependencies are not necessary
DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.9
- doc? ( >=dev-util/gtk-doc-0.9 )"
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-0.9 )"
DOCS="AUTHORS ChangeLog NEWS README TODO"
set_gtk_confdir() {
+
# An arch specific config directory is used on multilib systems
has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0}
+
}
pkg_setup() {
- # FIXME : USEify croco support (?)
- G2CONF="--with-croco \
- --enable-pixbuf-loader \
- --enable-gtk-theme \
- --disable-mozilla-plugin \
- $(use_enable gnome gnome-vfs) \
- $(use_with zlib svgz)"
+
+ if ! built_with_use x11-libs/cairo png; then
+ einfo "Please re-emerge x11-libs/cairo with the png USE flag set"
+ die "cairo needs the png flag set"
+ fi
+
+ G2CONF="--with-croco \
+ --enable-pixbuf-loader \
+ --enable-gtk-theme \
+ --disable-mozilla-plugin \
+ $(use_enable gnome gnome-vfs) \
+ $(use_with zlib svgz)"
+
}
src_install() {