summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libghttp/libghttp-1.0.9-r3.ebuild')
-rw-r--r--gnome-base/libghttp/libghttp-1.0.9-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnome-base/libghttp/libghttp-1.0.9-r3.ebuild b/gnome-base/libghttp/libghttp-1.0.9-r3.ebuild
new file mode 100644
index 000000000000..2886381e1ae7
--- /dev/null
+++ b/gnome-base/libghttp/libghttp-1.0.9-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libghttp/libghttp-1.0.9-r3.ebuild,v 1.1 2003/01/25 00:54:00 foser Exp $
+
+GNOME_TARBALL_SUFFIX="gz"
+inherit libtool gnome.org
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME http client library"
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ elibtoolize
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ # headers needed for Intermezzo (bug 11501)
+ insinto /usr/include/ghttp-1.0/
+ doins http*.h
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dohtml doc/*.html
+}