summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/outerspace')
-rw-r--r--games-strategy/outerspace/ChangeLog7
-rw-r--r--games-strategy/outerspace/files/digest-outerspace-0.5.653
-rw-r--r--games-strategy/outerspace/outerspace-0.5.65.ebuild41
3 files changed, 50 insertions, 1 deletions
diff --git a/games-strategy/outerspace/ChangeLog b/games-strategy/outerspace/ChangeLog
index 9f03929ee7e2..89a549ffc177 100644
--- a/games-strategy/outerspace/ChangeLog
+++ b/games-strategy/outerspace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/outerspace
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.8 2007/06/16 21:02:27 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.9 2007/08/12 00:27:49 nyhm Exp $
+
+*outerspace-0.5.65 (12 Aug 2007)
+
+ 12 Aug 2007; Tristan Heaven <nyhm@gentoo.org> +outerspace-0.5.65.ebuild:
+ Version bump
*outerspace-0.5.64 (16 Jun 2007)
diff --git a/games-strategy/outerspace/files/digest-outerspace-0.5.65 b/games-strategy/outerspace/files/digest-outerspace-0.5.65
new file mode 100644
index 000000000000..7a66bf5bd5d9
--- /dev/null
+++ b/games-strategy/outerspace/files/digest-outerspace-0.5.65
@@ -0,0 +1,3 @@
+MD5 587144fb267929d4720761ece10aa307 OuterSpace-0.5.65.tar.gz 2182005
+RMD160 9c019cf54d662c28a2db8bf5f9eeae9fb2ff2123 OuterSpace-0.5.65.tar.gz 2182005
+SHA256 a75cd981fffc2f889f9c9c616aafc5d02d1f62b62f616e255d883c31c685ce5f OuterSpace-0.5.65.tar.gz 2182005
diff --git a/games-strategy/outerspace/outerspace-0.5.65.ebuild b/games-strategy/outerspace/outerspace-0.5.65.ebuild
new file mode 100644
index 000000000000..743cb9e2fd76
--- /dev/null
+++ b/games-strategy/outerspace/outerspace-0.5.65.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.65.ebuild,v 1.1 2007/08/12 00:27:49 nyhm Exp $
+
+inherit eutils games
+
+MY_PN=${PN/outerspace/OuterSpace}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="on-line strategy game taking place in the dangerous universe"
+HOMEPAGE="http://www.ospace.net/"
+SRC_URI="mirror://sourceforge/ospace/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygame-1.7
+ >=dev-lang/python-2.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_LIBDIR@:$(games_get_libdir)/${PN}:" \
+ "${FILESDIR}"/${PN} > ${PN} \
+ || die "sed failed"
+}
+
+src_install() {
+ insinto "$(games_get_libdir)"/${PN}
+ doins -r osc.py lib libsrvr || die "doins lib failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r res || die "doins data failed"
+ dogamesbin ${PN} || die "dogamesbin failed"
+ newicon res/icon32.png ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN}
+ prepgamesdirs
+}