summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/openra/openra-20120504.ebuild')
-rw-r--r--games-strategy/openra/openra-20120504.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/games-strategy/openra/openra-20120504.ebuild b/games-strategy/openra/openra-20120504.ebuild
index 2e753aa02adc..8ca9752f0694 100644
--- a/games-strategy/openra/openra-20120504.ebuild
+++ b/games-strategy/openra/openra-20120504.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/openra/openra-20120504.ebuild,v 1.2 2012/05/04 17:31:14 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/openra/openra-20120504.ebuild,v 1.3 2012/05/14 11:49:35 hasufell Exp $
EAPI=3
@@ -69,12 +69,12 @@ pkg_postinst() {
games_pkg_postinst
gnome2_icon_cache_update
- if use cg ; then
- elog "If you have problems starting the game consider switching"
- elog "back to Graphics.Renderer=Gl in openra*.desktop or manually"
- elog "run:"
- elog "${PN} Game.Mods=\$mod Graphics.Renderer=Gl"
- fi
+ local myrenderer=$(usex cg Gl Cg)
+
+ elog "If you have problems starting the game consider switching"
+ elog "to Graphics.Renderer=${myrenderer} in openra*.desktop or manually"
+ elog "run:"
+ elog "${PN} Game.Mods=\$mod Graphics.Renderer=${myrenderer}"
}
pkg_postrm() {