summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/freeciv/freeciv-1.14.0-r1.ebuild')
-rw-r--r--games-strategy/freeciv/freeciv-1.14.0-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/games-strategy/freeciv/freeciv-1.14.0-r1.ebuild b/games-strategy/freeciv/freeciv-1.14.0-r1.ebuild
new file mode 100644
index 000000000000..8c026a5f0e96
--- /dev/null
+++ b/games-strategy/freeciv/freeciv-1.14.0-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-1.14.0-r1.ebuild,v 1.1 2003/09/10 05:27:31 vapier Exp $
+
+DESCRIPTION="multiplayer strategy game (Civilization Clone)"
+HOMEPAGE="http://www.freeciv.org/"
+SRC_URI="ftp://ftp.freeciv.org/freeciv/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
+IUSE="X Xaw3d gtk2 nls"
+
+DEPEND="X? ( virtual/x11 )
+ Xaw3d? ( x11-libs/Xaw3d )
+ gtk? ( ~x11-libs/gtk+-1.2.10-r4
+ >=media-libs/imlib-1.9.2
+ >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0-r2 )
+ gtk2? ( >=x11-libs/gtk+-2.0.0
+ >=dev-libs/atk-1.0.3
+ >=x11-libs/pango-1.2.1-r1
+ >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0-r2 )"
+RDEPEND="sys-libs/zlib"
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} --enable-client=no"
+
+ use X \
+ && myconf="${myconf} --enable-client=xaw --with-x"
+
+ use Xaw3d \
+ && myconf="${myconf} --enable-client=xaw3d --disable-gtktest"
+
+ use gtk \
+ && myconf="${myconf} --enable-client=gtk --enable-gtktest"
+
+ use gtk2 \
+ && myconf="${myconf} --enable-client=gtk-2.0 --enable-gtktest"
+
+
+ use nls \
+ || myconf="${myconf} --disable-nls"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-zlib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ install || die
+
+ use gtk || use gtk2 || /bin/install -D -m 644 \
+ ${S}/data/Freeciv \
+ ${D}/usr/X11R6/lib/X11/app-defaults/Freeciv
+
+
+ dodoc ABOUT-NLS AUTHORS BUGS ChangeLog HOWTOPLAY INSTALL NEWS PEOPLE README*
+ dodoc TODO freeciv_hackers_guide.txt
+}