summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-sports/foobillard/foobillard-2.9.ebuild')
-rw-r--r--games-sports/foobillard/foobillard-2.9.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/games-sports/foobillard/foobillard-2.9.ebuild b/games-sports/foobillard/foobillard-2.9.ebuild
index 04a86f14d527..ec154ea0d22d 100644
--- a/games-sports/foobillard/foobillard-2.9.ebuild
+++ b/games-sports/foobillard/foobillard-2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-2.9.ebuild,v 1.3 2004/03/20 12:59:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-2.9.ebuild,v 1.4 2004/05/30 05:11:32 mr_bones_ Exp $
inherit games
@@ -19,15 +19,17 @@ DEPEND="virtual/x11
>=media-libs/libpng-1.2.1
|| (
sdl? ( media-libs/libsdl )
- ( virtual/glu virtual/glut )
+ (
+ virtual/glu
+ virtual/glut )
)"
src_compile() {
local myconf=""
- [ "`ls /usr/include/GL/gl.h -al | awk '{print $NF}' | cut -d/ -f5`" == "nvidia" ] \
+ [ "$(ls /usr/include/GL/gl.h -al | awk '{print $NF}' | cut -d/ -f5)" == "nvidia" ] \
&& myconf="--enable-nvidia" \
|| myconf="--disable-nvidia"
- myconf="${myconf} `use_enable sdl SDL`"
+ myconf="${myconf} $(use_enable sdl SDL)"
use sdl \
&& myconf="${myconf} --disable-glut" \
|| myconf="${myconf} --enable-glut"
@@ -36,11 +38,11 @@ src_compile() {
--enable-sound \
${myconf} \
|| die
- emake || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die "make install failed"
dodoc README README.FONTS AUTHORS NEWS ChangeLog
prepgamesdirs
}