summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-server/halflife-clanmod/halflife-clanmod-1.81.24e.ebuild')
-rw-r--r--games-server/halflife-clanmod/halflife-clanmod-1.81.24e.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-server/halflife-clanmod/halflife-clanmod-1.81.24e.ebuild b/games-server/halflife-clanmod/halflife-clanmod-1.81.24e.ebuild
new file mode 100644
index 000000000000..02f5293db586
--- /dev/null
+++ b/games-server/halflife-clanmod/halflife-clanmod-1.81.24e.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/halflife-clanmod/halflife-clanmod-1.81.24e.ebuild,v 1.1 2003/09/10 05:51:11 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="tool for Half-Life mods which helps ease admining a server"
+HOMEPAGE="http://www.unitedadmins.com/clanmod.php"
+SRC_URI="mirror://sourceforge/clanmod/cm-${PV}-all-mods.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+
+RDEPEND="app-games/halflife-metamod"
+
+S=${WORKDIR}/cm-${PV}/addons/clanmod
+
+src_unpack() {
+ unpack ${A}
+ edos2unix `find -name '*.cfg' -o -name '*.sql' -o -name '*.txt'`
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/halflife/addons/clanmod
+ dodir ${dir}
+ cp -rf * ${D}/${dir}
+ prepgamesdirs
+}