summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/daimonin-client/ChangeLog9
-rw-r--r--games-rpg/daimonin-client/daimonin-client-0.9.7.1-r1.ebuild58
-rw-r--r--games-rpg/daimonin-client/files/daimonin-client-0.9.7.1-nozlib.patch38
3 files changed, 104 insertions, 1 deletions
diff --git a/games-rpg/daimonin-client/ChangeLog b/games-rpg/daimonin-client/ChangeLog
index d5cad190fbee..c002bc75b907 100644
--- a/games-rpg/daimonin-client/ChangeLog
+++ b/games-rpg/daimonin-client/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-rpg/daimonin-client
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/ChangeLog,v 1.22 2010/01/08 01:12:47 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/ChangeLog,v 1.23 2010/03/26 15:51:31 tupone Exp $
+
+*daimonin-client-0.9.7.1-r1 (26 Mar 2010)
+
+ 26 Mar 2010; Tupone Alfredo <tupone@gentoo.org>
+ +daimonin-client-0.9.7.1-r1.ebuild,
+ +files/daimonin-client-0.9.7.1-nozlib.patch:
+ Unbundle zlib. Bug #310849 by flameeyes@gentoo.org
08 Jan 2010; Joseph Jezak <josejx@gentoo.org>
daimonin-client-0.9.7.1.ebuild:
diff --git a/games-rpg/daimonin-client/daimonin-client-0.9.7.1-r1.ebuild b/games-rpg/daimonin-client/daimonin-client-0.9.7.1-r1.ebuild
new file mode 100644
index 000000000000..425bc5a58194
--- /dev/null
+++ b/games-rpg/daimonin-client/daimonin-client-0.9.7.1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/daimonin-client-0.9.7.1-r1.ebuild,v 1.1 2010/03/26 15:51:31 tupone Exp $
+
+EAPI=2
+inherit eutils autotools games
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="a graphical 2D tile-based MMORPG"
+HOMEPAGE="http://daimonin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/daimonin/${MY_P}.zip
+ mirror://sourceforge/daimonin/AllMusic.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ dev-games/physfs
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/daimonin/client/make/linux
+
+src_unpack() {
+ unpack ${MY_P}.zip
+ cd daimonin/client/media
+ rm -f *
+ unpack AllMusic.zip
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nozlib.patch
+ sed -i \
+ -e 's:$(d_datadir):$(DESTDIR)$(d_datadir):' \
+ -e '/PROGRAMS/s:daimonin-updater::' \
+ Makefile.am \
+ || die "sed failed"
+ chmod +x configure
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf --disable-simplelayout
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd ../..
+ dodoc README*
+ newicon skins/subred/bitmaps/pentagram.png ${PN}.png || die "newicon failed"
+ make_desktop_entry daimonin Daimonin
+ prepgamesdirs
+}
diff --git a/games-rpg/daimonin-client/files/daimonin-client-0.9.7.1-nozlib.patch b/games-rpg/daimonin-client/files/daimonin-client-0.9.7.1-nozlib.patch
new file mode 100644
index 000000000000..ed30c1977bc8
--- /dev/null
+++ b/games-rpg/daimonin-client/files/daimonin-client-0.9.7.1-nozlib.patch
@@ -0,0 +1,38 @@
+--- Makefile.am.old 2010-03-26 16:00:53.000000000 +0100
++++ Makefile.am 2010-03-26 16:01:39.000000000 +0100
+@@ -2,21 +2,16 @@
+ daimonin_PROGRAMS = daimonin daimonin-updater
+
+ daimonin_SOURCES = \
+- ../../src/adler32.c \
+ ../../src/book.c \
+ ../../src/buddy.c \
+ ../../src/chatfilter.c \
+ ../../src/client.c \
+ ../../src/commands.c \
+- ../../src/crc32.c \
+ ../../src/dialog.c \
+ ../../src/event.c \
+ ../../src/filewrap.c \
+ ../../src/group.c \
+ ../../src/ignore.c \
+- ../../src/inffast.c \
+- ../../src/inflate.c \
+- ../../src/inftrees.c \
+ ../../src/interface.c \
+ ../../src/inventory.c \
+ ../../src/item.c \
+@@ -31,11 +26,9 @@
+ ../../src/sound.c \
+ ../../src/sprite.c \
+ ../../src/textwin.c \
+- ../../src/uncompr.c \
+ ../../src/wrapper.c \
+- ../../src/widget.c \
+- ../../src/zutil.c
+-daimonin_LDADD = -lSDL_mixer -lSDL_image @SDL_LIBS@ @EXTRA_LIBS@ @PHYSFS_LIBS@
++ ../../src/widget.c
++daimonin_LDADD = -lSDL_mixer -lSDL_image @SDL_LIBS@ @EXTRA_LIBS@ @PHYSFS_LIBS@ -lz
+ daimonin_OBJDIR = objs
+
+ daimonin_updater_SOURCES = \