summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/freedroidrpg/ChangeLog8
-rw-r--r--games-rpg/freedroidrpg/files/freedroidrpg-0.14.1-syslibs.patch91
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-0.14.1.ebuild63
3 files changed, 161 insertions, 1 deletions
diff --git a/games-rpg/freedroidrpg/ChangeLog b/games-rpg/freedroidrpg/ChangeLog
index 489c4c3c0519..c468cc42ba43 100644
--- a/games-rpg/freedroidrpg/ChangeLog
+++ b/games-rpg/freedroidrpg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/freedroidrpg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/ChangeLog,v 1.27 2010/07/12 21:40:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/ChangeLog,v 1.28 2010/11/28 09:56:19 mr_bones_ Exp $
+
+*freedroidrpg-0.14.1 (28 Nov 2010)
+
+ 28 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +freedroidrpg-0.14.1.ebuild, +files/freedroidrpg-0.14.1-syslibs.patch:
+ version bump (bug #346945)
12 Jul 2010; Michael Sterrett <mr_bones_@gentoo.org>
freedroidrpg-0.13.ebuild, +files/freedroidrpg-0.13-sdl-gfx.patch,
diff --git a/games-rpg/freedroidrpg/files/freedroidrpg-0.14.1-syslibs.patch b/games-rpg/freedroidrpg/files/freedroidrpg-0.14.1-syslibs.patch
new file mode 100644
index 000000000000..c55531fd7b9c
--- /dev/null
+++ b/games-rpg/freedroidrpg/files/freedroidrpg-0.14.1-syslibs.patch
@@ -0,0 +1,91 @@
+diff -ru freedroidrpg-0.14.1.orig/configure.ac freedroidrpg-0.14.1/configure.ac
+--- freedroidrpg-0.14.1.orig/configure.ac 2010-11-26 17:47:26.000000000 -0500
++++ freedroidrpg-0.14.1/configure.ac 2010-11-28 04:40:12.524987716 -0500
+@@ -110,6 +110,14 @@
+ AC_MSG_ERROR([SDL_image library needed for FreedroidRPG!
+ see http://www.libsdl.org/]))
+
++AC_CHECK_LIB([SDL_gfx], [rotozoomSurface],,
++ AC_MSG_ERROR([SDL_gfx library needed to run FreedroidRPG
++see http://www.ferzkopp.net/Software/SDL_gfx-2.0/]))
++
++AC_CHECK_LIB([lua], [luaL_openlibs],,
++ AC_MSG_ERROR([lua library needed to run FreedroidRPG
++see http://www.lua.org/]))
++
+ AC_MSG_NOTICE([[Checking for optional SDL libraries:]])
+ AC_CHECK_LIB([SDL_mixer], [Mix_ChannelFinished],, AC_MSG_WARN([
+ --------------------------------------------------
+diff -ru freedroidrpg-0.14.1.orig/src/Makefile.am freedroidrpg-0.14.1/src/Makefile.am
+--- freedroidrpg-0.14.1.orig/src/Makefile.am 2010-11-26 17:41:13.000000000 -0500
++++ freedroidrpg-0.14.1/src/Makefile.am 2010-11-28 04:40:12.524987716 -0500
+@@ -1,9 +1,7 @@
+ ## Process this file with automake to produce Makefile.in
+
+-freedroidRPG_LDADD = ../lua/liblua.a
+-
+ if WIN32
+-freedroidRPG_LDADD += ../win32/freedroidRPG.coff
++freedroidRPG_LDADD = ../win32/freedroidRPG.coff
+ endif
+
+ bin_PROGRAMS = freedroidRPG
+@@ -22,7 +20,7 @@
+ enemy.c input.c keyboard.c main.c hud.c view.c automap.c BFont.c \
+ defs.h map.h vars.h takeover.h global.h \
+ proto.h struct.h system.h BFont.h \
+- SDL_rotozoom.c SDL_rotozoom.h open_gl.c open_gl_atlas.c mission.c chat.c light.c \
++ open_gl.c open_gl_atlas.c mission.c chat.c light.c \
+ getopt.c getopt1.c getopt.h scandir.c scandir.h sound.h sound_effects.c \
+ lang.h lists.c lists.h gen_savestruct.py savestruct.c savestruct.h string.c pathfinder.c \
+ benchmark.c \
+@@ -56,8 +54,3 @@
+ savestruct.c savestruct.h: struct.h gen_savestruct.py
+ python gen_savestruct.py struct.h savestruct
+
+-clean-local:
+- cd ../lua; make clean
+-
+-../lua/liblua.a:
+- cd ../lua; make CC=${CC} AR="${AR} rcu" RANLIB="${RANLIB}" liblua.a
+diff -ru freedroidrpg-0.14.1.orig/src/lua.c freedroidrpg-0.14.1/src/lua.c
+--- freedroidrpg-0.14.1.orig/src/lua.c 2010-11-26 17:41:13.000000000 -0500
++++ freedroidrpg-0.14.1/src/lua.c 2010-11-28 04:40:12.525987480 -0500
+@@ -37,9 +37,9 @@
+ #include "lvledit/lvledit_actions.h"
+ #include "lvledit/lvledit_map.h"
+
+-#include "../lua/lua.h"
+-#include "../lua/lauxlib.h"
+-#include "../lua/lualib.h"
++#include <lua.h>
++#include <lauxlib.h>
++#include <lualib.h>
+
+ /* Our Lua state for event execution */
+ lua_State *global_lua_state;
+diff -ru freedroidrpg-0.14.1.orig/src/luaconfig.c freedroidrpg-0.14.1/src/luaconfig.c
+--- freedroidrpg-0.14.1.orig/src/luaconfig.c 2010-11-26 17:41:13.000000000 -0500
++++ freedroidrpg-0.14.1/src/luaconfig.c 2010-11-28 04:40:32.263348025 -0500
+@@ -33,8 +33,8 @@
+ #include "global.h"
+ #include "proto.h"
+
+-#include "../lua/lua.h"
+-#include "../lua/lauxlib.h"
++#include <lua.h>
++#include <lauxlib.h>
+
+ /* Our Lua state for event execution (defined in lua.c) */
+ extern lua_State *global_lua_state;
+diff -ru freedroidrpg-0.14.1.orig/src/system.h freedroidrpg-0.14.1/src/system.h
+--- freedroidrpg-0.14.1.orig/src/system.h 2010-11-26 17:41:13.000000000 -0500
++++ freedroidrpg-0.14.1/src/system.h 2010-11-28 04:40:12.525987480 -0500
+@@ -111,6 +111,7 @@
+
+ #include "SDL.h"
+ #include "SDL_image.h"
++#include "SDL_rotozoom.h"
+
+ #ifdef HAVE_LIBSDL_MIXER
+ #include "SDL_mixer.h"
diff --git a/games-rpg/freedroidrpg/freedroidrpg-0.14.1.ebuild b/games-rpg/freedroidrpg/freedroidrpg-0.14.1.ebuild
new file mode 100644
index 000000000000..4990303c7fba
--- /dev/null
+++ b/games-rpg/freedroidrpg/freedroidrpg-0.14.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/freedroidrpg/freedroidrpg-0.14.1.ebuild,v 1.1 2010/11/28 09:56:19 mr_bones_ Exp $
+
+EAPI=2
+PYTHON_DEPEND="2"
+inherit autotools eutils python games
+
+DESCRIPTION="A modification of the classical Freedroid engine into an RPG"
+HOMEPAGE="http://freedroid.sourceforge.net/"
+SRC_URI="mirror://sourceforge/freedroid/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+RDEPEND="media-libs/libsdl[opengl?,video]
+ dev-lang/lua
+ media-libs/jpeg
+ media-libs/libpng
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-net
+ media-libs/sdl-mixer[vorbis]
+ >=media-libs/sdl-gfx-2.0.21
+ media-libs/libogg
+ media-libs/libvorbis
+ x11-libs/libX11
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ dev-lang/python"
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}
+
+src_prepare() {
+ rm -rf lua src/SDL_rotozoom*
+ epatch "${FILESDIR}"/${P}-syslibs.patch
+
+ python_convert_shebangs -r 2 .
+
+ # No need for executable game resources
+ find sound graphics -type f -exec chmod -c a-x '{}' +
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-fastmath \
+ $(use_enable opengl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}/${GAMES_BINDIR}/"{croppy,pngtoico,gluem,ungluem}
+ newicon win32/w32icon2_64x64.png ${PN}.png
+ make_desktop_entry freedroidRPG "Freedroid RPG"
+ prepgamesdirs
+}