summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/nwn-cep/nwn-cep-1.53.ebuild')
-rw-r--r--games-rpg/nwn-cep/nwn-cep-1.53.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-rpg/nwn-cep/nwn-cep-1.53.ebuild b/games-rpg/nwn-cep/nwn-cep-1.53.ebuild
new file mode 100644
index 000000000000..077c86c19a64
--- /dev/null
+++ b/games-rpg/nwn-cep/nwn-cep-1.53.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-cep/nwn-cep-1.53.ebuild,v 1.1 2006/07/25 19:36:31 wolf31o2 Exp $
+
+inherit games
+
+DESCRIPTION="The Community Expansion Pack is a high quality custom content addon
+for Neverwinter Nights"
+HOMEPAGE="http://nwn.bioware.com/players/cep.html"
+SRC_URI="cepv152_man.zip cepv${PV//.}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+RDEPEND="=games-rpg/nwn-1.67"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit http://nwvault.ign.com/cep/downloads/"
+ einfo "and download the .zip version."
+ einfo "Then move the file you download to:"
+ einfo "${DISTDIR}/${A}"
+}
+
+src_install() {
+ dodir "${GAMES_PREFIX_OPT}"/nwn/{hak,tlk,modules,cep}
+ cp *.hak "${D}/${GAMES_PREFIX_OPT}"/nwn/hak/ || die "hak failed"
+
+ cp Live/* "${D}/${GAMES_PREFIX_OPT}"/nwn/hak/ || die "hak2 failed"
+ cp cep.tlk "${D}/${GAMES_PREFIX_OPT}"/nwn/tlk/ || die "tlk failed"
+ cp *.mod "${D}/${GAMES_PREFIX_OPT}"/nwn/modules/ || die "mod failed"
+ cp *.pdf *.txt "${D}/${GAMES_PREFIX_OPT}"/nwn/cep/ || die "docs failed"
+ prepgamesdirs
+}