summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/stone-soup/ChangeLog10
-rw-r--r--games-roguelike/stone-soup/files/stone-soup-0.11.2-build.patch133
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.11.2.ebuild134
3 files changed, 275 insertions, 2 deletions
diff --git a/games-roguelike/stone-soup/ChangeLog b/games-roguelike/stone-soup/ChangeLog
index ff1e709a9538..801b9579ac8c 100644
--- a/games-roguelike/stone-soup/ChangeLog
+++ b/games-roguelike/stone-soup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-roguelike/stone-soup
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/stone-soup/ChangeLog,v 1.9 2012/12/13 18:17:05 hasufell Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/stone-soup/ChangeLog,v 1.10 2013/01/26 23:02:16 hasufell Exp $
+
+*stone-soup-0.11.2 (26 Jan 2013)
+
+ 26 Jan 2013; Julian Ospald <hasufell@gentoo.org> +stone-soup-0.11.2.ebuild,
+ +files/stone-soup-0.11.2-build.patch:
+ version bump
13 Dec 2012; Julian Ospald <hasufell@gentoo.org> -stone-soup-0.10.3.ebuild,
-files/stone-soup-0.10.3-build.patch, -stone-soup-0.11.1.ebuild:
diff --git a/games-roguelike/stone-soup/files/stone-soup-0.11.2-build.patch b/games-roguelike/stone-soup/files/stone-soup-0.11.2-build.patch
new file mode 100644
index 000000000000..772f670f04c6
--- /dev/null
+++ b/games-roguelike/stone-soup/files/stone-soup-0.11.2-build.patch
@@ -0,0 +1,133 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Oct 5 13:55:07 UTC 2012
+Subject: build system
+
+ respect flags and compiler
+
+--- source/Makefile
++++ source/Makefile
+@@ -112,7 +112,7 @@
+
+ else
+
+-CFOPTIMIZE := -O2
++CFOPTIMIZE := $(CXXFLAGS)
+
+ endif # USE_ICC
+
+@@ -120,21 +120,19 @@
+ CFOPTIMIZE += -flto=jobserver -fwhole-program
+ endif
+
+-CFOTHERS := -pipe $(EXTERNAL_FLAGS)
++CFOTHERS := $(EXTERNAL_FLAGS)
+ CFWARN := -Wall -Wformat-security
+ CFWARN_L := -Wundef
+
+ DEFINES := $(EXTERNAL_DEFINES)
+
+-LDFLAGS := $(EXTERNAL_LDFLAGS)
+-
+ #
+ # The GCC and GXX variables are set later.
+ #
+-AR = ar
+-RANLIB = ranlib
+-CC = $(GCC)
+-CXX = $(GXX)
++AR ?= ar
++RANLIB ?= ranlib
++CC ?= $(GCC)
++CXX ?= $(GXX)
+ RM = rm -f
+ COPY = cp
+ COPY_R = cp -r
+@@ -145,7 +143,7 @@
+ PNGCRUSH = $(COPY)
+ PNGCRUSH_LABEL = COPY
+ ADVPNG = advpng -z -4
+-PKGCONFIG = pkg-config
++PKGCONFIG ?= pkg-config
+ DOXYGEN = doxygen
+ DOXYGEN_SIMPLE_CONF = crawl_simple.doxy
+ DOXYGEN_ALL_CONF = crawl_all.doxy
+@@ -1228,7 +1226,6 @@
+ endif
+ [ -d $(prefix_fp)/$(bin_prefix) ] || mkdir -p $(prefix_fp)/$(bin_prefix)
+ $(COPY) $(GAME) $(prefix_fp)/$(bin_prefix)/
+- $(STRIP) $(prefix_fp)/$(bin_prefix)/$(GAME)
+ mkdir -p $(datadir_fp)/dat/des
+ mkdir -p $(datadir_fp)/dat/dlua
+ mkdir -p $(datadir_fp)/dat/clua
+@@ -1570,7 +1567,7 @@
+
+ .PHONY: build-rltiles
+ build-rltiles: .contrib-libs $(RLTILES)/dc-unrand.txt
+- +$(MAKE) -C $(RLTILES) all ARCH=$(ARCH) TILES=$(TILES)$(WEBTILES)
++ +$(MAKE) -C $(RLTILES) all ARCH=$(ARCH) DEBUG=$(DEBUG) TILES=$(TILES)$(WEBTILES)
+
+ $(TILEDEFSRCS) $(TILEDEFHDRS) $(ORIGTILEFILES): build-rltiles
+
+--- source/rltiles/Makefile
++++ source/rltiles/Makefile
+@@ -1,7 +1,7 @@
+ uname_S := $(shell uname -s)
+
+ ifneq (,$(findstring MINGW,$(uname_S)))
+-LDFLAGS += -lmingw32
++LIBS += -lmingw32
+ endif
+
+ # Note: since generation of tiles is done on the host, we don't care about
+@@ -10,7 +10,7 @@
+ # Also, cross-compilation with no system libraries for host rather than target
+ # is not supported. If host=target, contribs are enough.
+
+-CFLAGS := -O2 -g -Wall -Wextra -Wno-parentheses -Wno-unused-parameter
++CXXFLAGS += -Wall -Wextra -Wno-parentheses -Wno-unused-parameter
+
+ ifdef TILES
+ ifndef CONTRIB_SDL
+@@ -29,24 +29,24 @@
+ PNG_LIB := ../contrib/install/$(ARCH)/lib/libpng.a ../contrib/install/$(ARCH)/lib/libz.a
+ endif
+
+- CFLAGS += $(SDL_CFLAGS) $(PNG_INCLUDE)
+- LDFLAGS += $(SDL_LDFLAGS) $(PNG_LIB)
++ CXXFLAGS += $(SDL_CFLAGS) $(PNG_INCLUDE)
++ LIBS += $(SDL_LDFLAGS) $(PNG_LIB)
+
+- CFLAGS += -DUSE_TILE
++ CXXFLAGS += -DUSE_TILE
+ endif
+
+ ifdef DEBUG
+-CFLAGS += -O0 -DDEBUG -ggdb
++CXXFLAGS += -DDEBUG
+ endif
+
+ ifneq (,$(findstring MINGW,$(uname_S)))
+-LDFLAGS += -lgdi32 -lwinmm
++LIBS += -lgdi32 -lwinmm
+ endif
+ ifeq ($(uname_S),Darwin)
+ LDFLAGS += -framework AppKit -framework AudioUnit -framework Carbon -framework IOKit -framework OpenGL
+ endif
+ ifeq ($(uname_S),Linux)
+-LDFLAGS += -ldl -lpthread
++LIBS += -ldl -lpthread
+ endif
+
+ # Attempt to use a full compiler name, to make
+@@ -127,9 +127,9 @@
+ distclean: clean
+
+ %.o: %.cc .cflags
+- $(QUIET_HOSTCXX)$(HOSTCXX) $(CFLAGS) -Wp,-MMD,$*.d,-MT,$@ -c $< -o $@
++ $(CXX) $(CXXFLAGS) -Wp,-MD,$*.d,-MT,$@ -c $< -o $@
+
+ $(TILEGEN): $(OBJECTS)
+- $(QUIET_HOSTLINK)$(HOSTCXX) $(OBJECTS) -o $@ $(LDFLAGS)
++ $(CXX) $(CXXFLAGS) $(OBJECTS) -o $@ $(LDFLAGS) $(LIBS)
+
+ .PHONY: all clean distclean
diff --git a/games-roguelike/stone-soup/stone-soup-0.11.2.ebuild b/games-roguelike/stone-soup/stone-soup-0.11.2.ebuild
new file mode 100644
index 000000000000..00e7194406fa
--- /dev/null
+++ b/games-roguelike/stone-soup/stone-soup-0.11.2.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/stone-soup/stone-soup-0.11.2.ebuild,v 1.1 2013/01/26 23:02:16 hasufell Exp $
+
+## TODO
+# add sound support (no build switch, no sound files)
+
+EAPI=5
+VIRTUALX_REQUIRED="manual"
+inherit eutils gnome2-utils virtualx games
+
+MY_P="stone_soup-${PV}"
+DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
+HOMEPAGE="http://crawl.develz.org/wordpress/"
+SRC_URI="mirror://sourceforge/crawl-ref/Stone%20Soup/${PV}/${MY_P}-nodeps.tar.xz
+ http://dev.gentoo.org/~hasufell/distfiles/${PN}.png
+ http://dev.gentoo.org/~hasufell/distfiles/${PN}.svg"
+
+# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
+# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
+# Public Domain|CC0: most of tiles
+# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
+LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0-Universal MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ncurses test +tiles"
+# test is broken
+# see https://crawl.develz.org/mantis/view.php?id=6121
+#RESTRICT="!debug? ( test )"
+RESTRICT="test"
+
+RDEPEND="
+ dev-db/sqlite:3
+ sys-libs/zlib
+ tiles? (
+ media-libs/freetype:2
+ media-libs/libpng:0
+ media-libs/libsdl[X,opengl,video]
+ media-libs/sdl-image[png]
+ )
+ ncurses? ( sys-libs/ncurses )
+ >=dev-lang/lua-5.1.0[deprecated]"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-devel/flex
+ virtual/yacc
+ tiles? (
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( ${VIRTUALX_DEPEND} )
+ )"
+
+REQUIRED_USE="|| ( ncurses tiles )"
+
+S=${WORKDIR}/${MY_P}/source
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+
+# if use test ; then
+# cp -av "${WORKDIR}/${MY_P}" "${WORKDIR}/${MY_P}_test" \
+# || die "setting up test-dir failed"
+# fi
+}
+
+src_compile() {
+ S_TEST=${WORKDIR}/${MY_P}_test/source
+
+ # leave DATADIR at the top
+ myemakeargs=(
+ DATADIR="${GAMES_DATADIR}/${PN}"
+ V=1
+ prefix="${GAMES_PREFIX}"
+ SAVEDIR="~/.crawl"
+ $(usex debug "FULLDEBUG=y DEBUG=y" "")
+ )
+
+ if use ncurses ; then
+ emake ${myemakeargs[@]}
+ # move it in case we build both variants
+ use tiles && { mv crawl "${WORKDIR}"/crawl-ncurses || die ;}
+ fi
+
+ if use tiles ; then
+ emake clean
+ emake ${myemakeargs[@]} "TILES=y"
+ fi
+
+ # for test to work we need to compile with unset DATADIR
+# if use test ; then
+# emake ${myemakeargs[@]:1} -C "${S_TEST}"
+# fi
+}
+
+src_install() {
+ emake ${myemakeargs[@]} $(usex tiles "TILES=y" "") DESTDIR="${D}" install
+ [[ -e "${WORKDIR}"/crawl-ncurses ]] && dogamesbin "${WORKDIR}"/crawl-ncurses
+
+ # don't relocate docs, needed at runtime
+ rm -rf "${D}${GAMES_DATADIR}"/${PN}/docs/license
+ dodoc "${WORKDIR}"/${MY_P}/README.{txt,pdf}
+
+ # icons and menu for graphical build
+ if use tiles ; then
+ doicon -s 48 "${DISTDIR}"/${PN}.png
+ doicon -s scalable "${DISTDIR}"/${PN}.svg
+ make_desktop_entry crawl
+ fi
+
+ prepgamesdirs
+}
+
+src_test() {
+ $(usex tiles "X" "")emake ${myemakeargs[@]:1} -C "${S_TEST}" test
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+
+ echo
+ elog "Your old config folder under '~/.crawl' is not compatible"
+ elog "with the new version. Remove it."
+ echo
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}