summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/ivan')
-rw-r--r--games-roguelike/ivan/ChangeLog6
-rw-r--r--games-roguelike/ivan/files/digest-ivan-0.502
-rw-r--r--games-roguelike/ivan/files/ivan-0.50-gcc41.patch58
-rw-r--r--games-roguelike/ivan/ivan-0.50.ebuild8
4 files changed, 72 insertions, 2 deletions
diff --git a/games-roguelike/ivan/ChangeLog b/games-roguelike/ivan/ChangeLog
index c98f1b2193b4..d4694e4ab4e2 100644
--- a/games-roguelike/ivan/ChangeLog
+++ b/games-roguelike/ivan/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/ivan
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ChangeLog,v 1.7 2006/01/05 05:38:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ChangeLog,v 1.8 2006/05/21 14:28:57 tupone Exp $
+
+ 21 May 2006; <Tupone@gentoo.org> +files/ivan-0.50-gcc41.patch,
+ ivan-0.50.ebuild:
+ Fix for gcc-4.1
05 Jan 2006; Michael Sterrett <mr_bones_@gentoo.org> ivan-0.50.ebuild:
turn off -O to prevent segfault in reponse to bug #113627
diff --git a/games-roguelike/ivan/files/digest-ivan-0.50 b/games-roguelike/ivan/files/digest-ivan-0.50
index 6e6c683d13e0..5f1475aa8465 100644
--- a/games-roguelike/ivan/files/digest-ivan-0.50
+++ b/games-roguelike/ivan/files/digest-ivan-0.50
@@ -1 +1,3 @@
MD5 88de761ea3ed34a977cd412ff7d2a36e ivan-0.50.tar.gz 803651
+RMD160 7e84340cd8fdfbdaaf7fde730fc0a76b137e2e91 ivan-0.50.tar.gz 803651
+SHA256 d8bc588ad902f27906ab34c2f8a9cace03867b45ff6a57025e046931f36ad480 ivan-0.50.tar.gz 803651
diff --git a/games-roguelike/ivan/files/ivan-0.50-gcc41.patch b/games-roguelike/ivan/files/ivan-0.50-gcc41.patch
new file mode 100644
index 000000000000..4562ce144a72
--- /dev/null
+++ b/games-roguelike/ivan/files/ivan-0.50-gcc41.patch
@@ -0,0 +1,58 @@
+--- FeLib/Include/fearray.h.old 2006-05-21 16:02:19.000000000 +0200
++++ FeLib/Include/fearray.h 2006-05-21 16:03:16.000000000 +0200
+@@ -34,7 +34,7 @@
+ };
+
+ template <class type>
+-inline fearray<type>::fearray<type>(const fearray<type>& A)
++inline fearray<type>::fearray(const fearray<type>& A)
+ : Data(A.Data), Size(A.Size)
+ {
+ if(Data)
+@@ -42,7 +42,7 @@
+ }
+
+ template <class type>
+-inline fearray<type>::fearray<type>(const type* Array, sizetype Size)
++inline fearray<type>::fearray(const type* Array, sizetype Size)
+ : Size(Size)
+ {
+ char* Ptr = new char[Size * sizeof(type) + sizeof(ulong)];
+--- Main/Source/script.cpp.old 2006-05-21 16:14:43.000000000 +0200
++++ Main/Source/script.cpp 2006-05-21 16:16:12.000000000 +0200
+@@ -471,7 +471,7 @@
+ INIT_ENTRY(Flags);
+ }
+
+-contentscript<character>::contentscript<character>()
++contentscript<character>::contentscript()
+ : INIT(Team, DEFAULT_TEAM),
+ INIT(Flags, 0)
+ { }
+@@ -498,7 +498,7 @@
+ return Instance;
+ }
+
+-contentscript<item>::contentscript<item>()
++contentscript<item>::contentscript()
+ : INIT(Category, ANY_CATEGORY),
+ INIT(MinPrice, 0),
+ INIT(MaxPrice, MAX_PRICE),
+@@ -592,7 +592,7 @@
+ INIT_ENTRY(IsInside);
+ }
+
+-contentscript<olterrain>::contentscript<olterrain>()
++contentscript<olterrain>::contentscript()
+ : INIT(VisualEffects, 0),
+ INIT(AttachedArea, DEFAULT_ATTACHED_AREA),
+ INIT(AttachedEntry, DEFAULT_ATTACHED_ENTRY)
+@@ -679,7 +679,7 @@
+ }
+ }
+
+-template <class type, class contenttype> contentmap<type, contenttype>::contentmap<type, contenttype>() : ContentMap(0) { }
++template <class type, class contenttype> contentmap<type, contenttype>::contentmap() : ContentMap(0) { }
+
+ template <class type, class contenttype> contentmap<type, contenttype>::~contentmap<type, contenttype>()
+ {
diff --git a/games-roguelike/ivan/ivan-0.50.ebuild b/games-roguelike/ivan/ivan-0.50.ebuild
index 9afafa061c90..6904097df7c4 100644
--- a/games-roguelike/ivan/ivan-0.50.ebuild
+++ b/games-roguelike/ivan/ivan-0.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ivan-0.50.ebuild,v 1.3 2006/01/05 05:38:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ivan-0.50.ebuild,v 1.4 2006/05/21 14:28:57 tupone Exp $
inherit flag-o-matic games
@@ -15,6 +15,12 @@ IUSE=""
DEPEND=">=media-libs/libsdl-1.2.0"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}"-gcc41.patch
+}
+
src_compile() {
replace-flags -O? -O0 #bug #113627
egamesconf || die