summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/hoh-bin/ChangeLog7
-rw-r--r--games-puzzle/hoh-bin/Manifest4
-rw-r--r--games-puzzle/hoh-bin/files/digest-hoh-bin-1.011
-rw-r--r--games-puzzle/hoh-bin/hoh-bin-1.01.ebuild38
4 files changed, 47 insertions, 3 deletions
diff --git a/games-puzzle/hoh-bin/ChangeLog b/games-puzzle/hoh-bin/ChangeLog
index ed409e538169..aaba883ebcd1 100644
--- a/games-puzzle/hoh-bin/ChangeLog
+++ b/games-puzzle/hoh-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/hoh-bin
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hoh-bin/ChangeLog,v 1.1 2004/01/05 07:51:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hoh-bin/ChangeLog,v 1.2 2004/01/13 21:46:44 mr_bones_ Exp $
+
+*hoh-bin-1.01 (13 Jan 2004)
+
+ 13 Jan 2004; Michael Sterrett <mr_bones_@gentoo.org> hoh-bin-1.01.ebuild:
+ version bump
*hoh-bin-1.0 (04 Jan 2004)
diff --git a/games-puzzle/hoh-bin/Manifest b/games-puzzle/hoh-bin/Manifest
index 2fa0905343a5..0d271179bf66 100644
--- a/games-puzzle/hoh-bin/Manifest
+++ b/games-puzzle/hoh-bin/Manifest
@@ -1,6 +1,6 @@
MD5 c16dd70bd705d57336828272d1794c2b hoh-bin-1.0.ebuild 1110
MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
-MD5 cf115298d6a4d8f2769abbe318b62ade ChangeLog 430
-MD5 882f2132e191eca0be60e6d717fac4c7 hoh-bin-1.01.ebuild 1112
+MD5 3fe261f2ff852d6f8ed5f581dab039b0 ChangeLog 551
+MD5 979ab985e187341c53941de65934ffb1 hoh-bin-1.01.ebuild 1113
MD5 8d0a42d849cb14f23285c2a747566b66 files/digest-hoh-bin-1.0 64
MD5 4ee425c170cf9c5c39148ac939ae3488 files/digest-hoh-bin-1.01 65
diff --git a/games-puzzle/hoh-bin/files/digest-hoh-bin-1.01 b/games-puzzle/hoh-bin/files/digest-hoh-bin-1.01
new file mode 100644
index 000000000000..d616ed0a0937
--- /dev/null
+++ b/games-puzzle/hoh-bin/files/digest-hoh-bin-1.01
@@ -0,0 +1 @@
+MD5 927d1a1dee927b5c495bfd39b0458a45 hohlin-101.tar.bz2 14808528
diff --git a/games-puzzle/hoh-bin/hoh-bin-1.01.ebuild b/games-puzzle/hoh-bin/hoh-bin-1.01.ebuild
new file mode 100644
index 000000000000..7a40d988e7ac
--- /dev/null
+++ b/games-puzzle/hoh-bin/hoh-bin-1.01.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hoh-bin/hoh-bin-1.01.ebuild,v 1.1 2004/01/13 21:46:44 mr_bones_ Exp $
+
+inherit games
+
+S="${WORKDIR}/hoh-install-${PV}"
+DESCRIPTION="PC remake of the spectrum game"
+HOMEPAGE="http://retrospec.sgn.net/games/hoh/"
+SRC_URI="http://retrospec.sgn.net/download.php?id=63\&path=games/hoh/bin/hohlin-${PV/./}.tar.bz2"
+
+RESTRICT="nostrip"
+KEYWORDS="x86"
+LICENSE="free-noncomm"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/x11"
+
+src_compile() {
+ cat > "${T}/hoh" <<-EOF
+ #!/bin/bash
+ export LD_LIBRARY_PATH="${GAMES_PREFIX_OPT}/HoH/data/runtime"
+ cd "${GAMES_PREFIX_OPT}/HoH/data"
+ exec ./HoH \$@
+EOF
+}
+
+src_install() {
+ local DATADIR="${GAMES_PREFIX_OPT}/HoH/data"
+ local DOCDIR="${GAMES_PREFIX_OPT}/HoH/docs"
+
+ dogamesbin "${T}/hoh" || die "dogames bin failed"
+ dodir "${DATADIR}" "${DOCDIR}" || die "dodir failed"
+ cp -af data/* "${D}/${DATADIR}/" || die "cp failed (data)"
+ cp -af docs/* "${D}/${DOCDIR}/" || die "cp failed (docs)"
+ prepgamesdirs
+}