summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/toppler/toppler-1.1.6.ebuild')
-rw-r--r--games-puzzle/toppler/toppler-1.1.6.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/games-puzzle/toppler/toppler-1.1.6.ebuild b/games-puzzle/toppler/toppler-1.1.6.ebuild
index 661fc5cde084..9c9cee554cd6 100644
--- a/games-puzzle/toppler/toppler-1.1.6.ebuild
+++ b/games-puzzle/toppler/toppler-1.1.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/toppler/toppler-1.1.6.ebuild,v 1.4 2013/02/24 11:33:09 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/toppler/toppler-1.1.6.ebuild,v 1.5 2014/08/28 07:43:13 mr_bones_ Exp $
EAPI=5
-inherit games
+inherit eutils games
DESCRIPTION="Reimplementation of Nebulous using SDL"
HOMEPAGE="http://toppler.sourceforge.net/"
@@ -20,14 +20,15 @@ RDEPEND="media-libs/libsdl[video]
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
src_configure() {
egamesconf $(use_enable nls)
}
src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog README
+ default
prepgamesdirs
}