summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/OilWar/OilWar-1.2.1.ebuild')
-rw-r--r--games-misc/OilWar/OilWar-1.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-misc/OilWar/OilWar-1.2.1.ebuild b/games-misc/OilWar/OilWar-1.2.1.ebuild
new file mode 100644
index 000000000000..b57bc9c8a619
--- /dev/null
+++ b/games-misc/OilWar/OilWar-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/OilWar/OilWar-1.2.1.ebuild,v 1.1 2004/07/21 00:53:15 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Evil army is attacking your country and tries to steal your oil"
+HOMEPAGE="http://www.2ndpoint.fi/projektit/oilwar.html"
+SRC_URI="http://www.2ndpoint.fi/projektit/filut/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i '/^datafiledir/s:/games/:/:' Makefile.in || die "sed failed"
+}
+
+src_compile() {
+ egamesconf --enable-sound || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}