summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/quake3-bin')
-rw-r--r--games-fps/quake3-bin/ChangeLog8
-rw-r--r--games-fps/quake3-bin/quake3-bin-1.31.ebuild82
-rw-r--r--games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild28
3 files changed, 80 insertions, 38 deletions
diff --git a/games-fps/quake3-bin/ChangeLog b/games-fps/quake3-bin/ChangeLog
index 80355345c32f..389bf5089a29 100644
--- a/games-fps/quake3-bin/ChangeLog
+++ b/games-fps/quake3-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quake3-bin
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/ChangeLog,v 1.8 2006/03/15 22:24:16 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/ChangeLog,v 1.9 2006/03/22 21:52:01 wolf31o2 Exp $
+
+ 22 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ quake3-bin-1.31.ebuild, quake3-bin-1.32b-r4.ebuild:
+ Fixed up dedicated USE invocation so we only copy the dedicated files when
+ necessary and synced 1.32b to 1.31 ebuild. Also added code to properly
+ symlink pak0.pk3 from baseq3 and missionpack, if USE=cdinstall.
15 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
quake3-bin-1.31.ebuild, quake3-bin-1.32b-r4.ebuild:
diff --git a/games-fps/quake3-bin/quake3-bin-1.31.ebuild b/games-fps/quake3-bin/quake3-bin-1.31.ebuild
index 70882fc54961..90b24f5f6a4f 100644
--- a/games-fps/quake3-bin/quake3-bin-1.31.ebuild
+++ b/games-fps/quake3-bin/quake3-bin-1.31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/quake3-bin-1.31.ebuild,v 1.4 2006/03/15 22:24:16 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/quake3-bin-1.31.ebuild,v 1.5 2006/03/22 21:52:01 wolf31o2 Exp $
inherit eutils games
@@ -11,7 +11,7 @@ SRC_URI="mirror://idsoftware/quake3/linux/linuxq3apoint-${PV}.x86.run"
LICENSE="Q3AEULA"
SLOT="0"
KEYWORDS="-* amd64 x86"
-IUSE="dedicated opengl"
+IUSE="cdinstall dedicated opengl"
RESTRICT="nostrip"
RDEPEND="sys-libs/glibc
@@ -31,16 +31,24 @@ RDEPEND="sys-libs/glibc
app-emulation/emul-linux-x86-baselibs
opengl? (
app-emulation/emul-linux-x86-xlibs
- || ( >=media-video/nvidia-glx-1.0.6629-r3
- >=x11-drivers/ati-drivers-8.8.25-r1 ) ) )"
+ || (
+ >=media-video/nvidia-glx-1.0.6629-r3
+ >=x11-drivers/ati-drivers-8.8.25-r1 ) ) )
+ games-fps/quake3-data"
S=${WORKDIR}
+
+GAMES_CHECK_LICENSE="yes"
dir=${GAMES_PREFIX_OPT}/quake3
Ddir=${D}/${dir}
pkg_setup() {
- check_license Q3AEULA
games_pkg_setup
+ if use cdinstall
+ then
+ built_with_use games-fps/quake3-data cdinstall \
+ || die "You must install quake3-data with USE=cdinstall to get the required data."
+ fi
}
src_unpack() {
@@ -48,41 +56,65 @@ src_unpack() {
}
src_install() {
- insinto ${dir}/baseq3
- doins baseq3/*.pk3
- mv Help ${Ddir}
- insinto ${dir}/missionpack
- doins missionpack/*.pk3
+ if use cdinstall ; then
+ dodir ${dir}/{baseq3,missionpack}
+ for pk3 in baseq3/*.pk3 missionpack/*.pk3 ; do
+ dosym ${GAMES_DATADIR}/quake3/${pk3} ${dir}/${pk3}
+ done
+ dosym ${GAMES_DATADIR}/quake3/pak0.pk3 ${dir}/baseq3/pak0.pk3
+ dosym ${GAMES_DATADIR}/quake3/missionpack/pak0.pk3 \
+ ${dir}/missionpack/pak0.pk3
+ else
+ insinto ${dir}/baseq3
+ doins baseq3/*.pk3 || die "ins baseq3"
+ insinto ${dir}/missionpack
+ doins missionpack/*.pk3 || die "ins missionpack"
+ fi
+
+ insinto ${dir}
+ doins -r Docs pb || die "ins docs/pb"
exeinto ${dir}
insinto ${dir}
- doexe bin/x86/{quake3.x86,q3ded} || die "doexe"
+ doexe bin/Linux/x86/quake3.x86 || die "doexe"
doins quake3.xpm README* Q3A_EULA.txt
games_make_wrapper quake3-bin ./quake3.x86 "${dir}" "${dir}"
- games_make_wrapper q3ded-bin ./q3ded "${dir}" "${dir}"
-
- newinitd "${FILESDIR}"/q3ded.rc q3ded
- newconfd "${FILESDIR}"/q3ded.conf.d q3ded
- doicon quake3.xpm
+ if use dedicated
+ then
+ doexe bin/Linux/x86/q3ded || die "doexe q3ded"
+ games_make_wrapper q3ded-bin ./q3ded "${dir}" "${dir}"
+ newinitd "${FILESDIR}"/q3ded.rc q3ded
+ newconfd "${FILESDIR}"/q3ded.conf.d q3ded
+ fi
+ newicon quake3.xpm quake3-bin.xpm
prepgamesdirs
- make_desktop_entry quake3-bin "Quake III Arena (binary)" quake3.xpm
+ make_desktop_entry quake3-bin "Quake III Arena (binary)" quake3-bin.xpm
}
pkg_postinst() {
games_pkg_postinst
echo
- ewarn "There are two possible security bugs in this package, both causing a denial"
- ewarn "of service. One affects the game when running a server, the other when running"
- ewarn "as a client. For more information, see bug #82149."
- echo
- einfo "You need to copy pak0.pk3 from your Quake3 CD into ${dir}/baseq3."
- einfo "Or if you have got a Window installation of Q3 make a symlink to save space."
- echo
+ ewarn "There are two possible security bugs in this package, both causing a"
+ ewarn "denial of service. One affects the game when running a server, the"
+ ewarn "other when running as a client."
+ ewarn "For more information, please see bug #82149."
+ if ! use cdinstall ; then
+ echo
+ einfo "You need to copy pak0.pk3 from your Quake3 CD into ${dir}/baseq3."
+ einfo "Or if you have got a Window installation of Q3 make a symlink to save space."
+ fi
if use dedicated; then
+ echo
einfo "To start a dedicated server, run"
- einfo "\t/etc/init.d/q3ded start"
+ einfo " /etc/init.d/q3ded start"
echo
einfo "The dedicated server is started under the ${GAMES_USER_DED} user account."
fi
+
+ # IA32 Emulation required for amd64
+ if use amd64 ; then
+ echo
+ ewarn "NOTE: IA32 Emulation must be compiled into your kernel for Quake3 to run."
+ fi
}
diff --git a/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild b/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild
index 45e95a30c40e..5daf7c192b29 100644
--- a/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild
+++ b/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild,v 1.5 2006/03/15 22:24:16 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-bin/quake3-bin-1.32b-r4.ebuild,v 1.6 2006/03/22 21:52:01 wolf31o2 Exp $
inherit eutils games
@@ -46,10 +46,8 @@ pkg_setup() {
games_pkg_setup
if use cdinstall
then
- if [ ! built_with_use games-fps/quake3-data cdinstall ]
- then
- die "You must install quake3-data with USE=cdinstall to get the required data."
- fi
+ built_with_use games-fps/quake3-data cdinstall \
+ || die "You must install quake3-data with USE=cdinstall to get the required data."
fi
}
@@ -63,6 +61,9 @@ src_install() {
for pk3 in baseq3/*.pk3 missionpack/*.pk3 ; do
dosym ${GAMES_DATADIR}/quake3/${pk3} ${dir}/${pk3}
done
+ dosym ${GAMES_DATADIR}/quake3/pak0.pk3 ${dir}/baseq3/pak0.pk3
+ dosym ${GAMES_DATADIR}/quake3/missionpack/pak0.pk3 \
+ ${dir}/missionpack/pak0.pk3
else
insinto ${dir}/baseq3
doins baseq3/*.pk3 || die "ins baseq3"
@@ -75,13 +76,16 @@ src_install() {
exeinto ${dir}
insinto ${dir}
- doexe bin/Linux/x86/{quake3.x86,q3ded} || die "doexe"
+ doexe bin/Linux/x86/quake3.x86 || die "doexe"
doins quake3.xpm README* Q3A_EULA.txt
games_make_wrapper quake3-bin ./quake3.x86 "${dir}" "${dir}"
- games_make_wrapper q3ded-bin ./q3ded "${dir}" "${dir}"
-
- newinitd "${FILESDIR}"/q3ded.rc q3ded
- newconfd "${FILESDIR}"/q3ded.conf.d q3ded
+ if use dedicated
+ then
+ doexe bin/Linux/x86/q3ded || die "doexe q3ded"
+ games_make_wrapper q3ded-bin ./q3ded "${dir}" "${dir}"
+ newinitd "${FILESDIR}"/q3ded.rc q3ded
+ newconfd "${FILESDIR}"/q3ded.conf.d q3ded
+ fi
newicon quake3.xpm quake3-bin.xpm
prepgamesdirs
@@ -93,8 +97,8 @@ pkg_postinst() {
echo
ewarn "There are two possible security bugs in this package, both causing a"
ewarn "denial of service. One affects the game when running a server, the"
- ewarn "other when running as a client. For more information, please see bug"
- ewarn "#82149."
+ ewarn "other when running as a client."
+ ewarn "For more information, please see bug #82149."
if ! use cdinstall ; then
echo
einfo "You need to copy pak0.pk3 from your Quake3 CD into ${dir}/baseq3."