summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/gngb/gngb-20020819.ebuild')
-rw-r--r--games-emulation/gngb/gngb-20020819.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/games-emulation/gngb/gngb-20020819.ebuild b/games-emulation/gngb/gngb-20020819.ebuild
new file mode 100644
index 000000000000..e2d34652694d
--- /dev/null
+++ b/games-emulation/gngb/gngb-20020819.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngb/gngb-20020819.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+DESCRIPTION="gngb - Gameboy / Gameboy Color emulator"
+HOMEPAGE="http://membres.lycos.fr/frogus/gngb/"
+SRC_URI="http://membres.lycos.fr/frogus/gngb/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc"
+SLOT="0"
+IUSE="opengl"
+
+RDEPEND="media-libs/libsdl
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ use opengl || myconf=" --with-gl "
+ econf ${myconf}
+ emake || die
+}
+
+src_install() {
+ dodoc NEWS README TODO INSTALL AUTHORS
+ make DESTDIR=${D} install || die
+}