summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/grhino/grhino-0.16.0.ebuild')
-rw-r--r--games-board/grhino/grhino-0.16.0.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/games-board/grhino/grhino-0.16.0.ebuild b/games-board/grhino/grhino-0.16.0.ebuild
deleted file mode 100644
index cb82f4bfa454..000000000000
--- a/games-board/grhino/grhino-0.16.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/grhino/grhino-0.16.0.ebuild,v 1.9 2009/10/25 15:54:54 maekke Exp $
-
-EAPI=2
-inherit eutils games
-
-DESCRIPTION="Reversi game for GNOME, supporting the Go/Game Text Protocol"
-HOMEPAGE="http://rhino.sourceforge.net/"
-SRC_URI="mirror://sourceforge/rhino/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="gnome gtp nls"
-
-RDEPEND="gnome? ( =gnome-base/libgnomeui-2* )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch
- sed -i '/^(\|locale\|help\|omf\|icon\|)/s:@datadir@:/usr/share:' \
- Makefile.in \
- || die "sed failed"
-}
-
-src_configure() {
- if use gnome || use gtp; then
- egamesconf \
- --localedir=/usr/share/locale \
- $(use_enable gnome) \
- $(use_enable gtp) \
- $(use_enable nls)
- else
- egamesconf \
- --localedir=/usr/share/locale \
- --enable-gtp \
- --disable-gnome \
- $(use_enable nls)
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc ChangeLog NEWS README TODO
-
- if use gnome; then
- make_desktop_entry ${PN} GRhino
- fi
-
- prepgamesdirs
-}