summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/ggz-gtk-client/ggz-gtk-client-0.0.9.ebuild')
-rw-r--r--games-board/ggz-gtk-client/ggz-gtk-client-0.0.9.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/games-board/ggz-gtk-client/ggz-gtk-client-0.0.9.ebuild b/games-board/ggz-gtk-client/ggz-gtk-client-0.0.9.ebuild
index 8cb0f3796b60..99460de1c1db 100644
--- a/games-board/ggz-gtk-client/ggz-gtk-client-0.0.9.ebuild
+++ b/games-board/ggz-gtk-client/ggz-gtk-client-0.0.9.ebuild
@@ -1,19 +1,20 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-gtk-client/ggz-gtk-client-0.0.9.ebuild,v 1.3 2005/09/20 14:52:59 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-gtk-client/ggz-gtk-client-0.0.9.ebuild,v 1.4 2006/03/24 16:30:44 wolf31o2 Exp $
-inherit eutils
+inherit eutils games
DESCRIPTION="The gtk client for GGZ Gaming Zone"
HOMEPAGE="http://ggz.sourceforge.net/"
-SRC_URI="http://ftp.ggzgamingzone.org/pub/ggz/${PV}/${P}.tar.gz"
+SRC_URI="http://ftp.ggzgamingzone.org/pub/ggz/${PV}/${P}.tar.gz
+ http://mirrors.ibiblio.org/pub/mirrors/ggzgamingzone/ggz/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE="nls"
-DEPEND=">=dev-games/ggz-client-libs-${PV}
+DEPEND="~dev-games/ggz-client-libs-${PV}
=x11-libs/gtk+-2* "
src_unpack() {
@@ -24,12 +25,10 @@ src_unpack() {
}
src_compile() {
- local myconf="--enable-gtk=gtk2"
-
- econf \
+ egamesconf \
--disable-debug \
$(use_enable nls) \
- ${myconf} \
+ --enable-gtk=gtk2 \
|| die
emake || die
}
@@ -37,4 +36,5 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS QuickStart.GGZ README* TODO
+ prepgamesdirs
}