summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/blokish')
-rw-r--r--games-board/blokish/ChangeLog9
-rw-r--r--games-board/blokish/blokish-0.9.4.ebuild46
-rw-r--r--games-board/blokish/files/digest-blokish-0.9.43
3 files changed, 56 insertions, 2 deletions
diff --git a/games-board/blokish/ChangeLog b/games-board/blokish/ChangeLog
index 52c271acdbff..5fa9c1306996 100644
--- a/games-board/blokish/ChangeLog
+++ b/games-board/blokish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/blokish
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/ChangeLog,v 1.3 2006/11/19 21:43:50 nyhm Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/ChangeLog,v 1.4 2007/10/29 23:19:00 tupone Exp $
+
+*blokish-0.9.4 (29 Oct 2007)
+
+ 29 Oct 2007; Tupone Alfredo <tupone@gentoo.org> +blokish-0.9.4.ebuild:
+ Version bump
19 Nov 2006; Tristan Heaven <nyhm@gentoo.org> blokish-0.9.3.ebuild:
Use wxwidgets eclass and install desktop entry
diff --git a/games-board/blokish/blokish-0.9.4.ebuild b/games-board/blokish/blokish-0.9.4.ebuild
new file mode 100644
index 000000000000..40e5c21c3a04
--- /dev/null
+++ b/games-board/blokish/blokish-0.9.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/blokish-0.9.4.ebuild,v 1.1 2007/10/29 23:19:00 tupone Exp $
+
+inherit eutils wxwidgets games
+
+MY_P="${PN}_v${PV}"
+DESCRIPTION="Open source clone of the four-player board game Blokus"
+HOMEPAGE="http://sourceforge.net/projects/blokish/"
+SRC_URI="mirror://sourceforge/blokish/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=x11-libs/wxGTK-2.6*
+ virtual/opengl"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ WX_GTK_VER=2.6 need-wxwidgets unicode
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s:wx-config:${WX_CONFIG}:" \
+ configure makefile.in \
+ || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon src/${PN}.xpm
+ make_desktop_entry ${PN} Blokish ${PN}.xpm
+
+ dodoc AUTHORS ChangeLog README
+ dohtml docs/*
+ prepgamesdirs
+}
diff --git a/games-board/blokish/files/digest-blokish-0.9.4 b/games-board/blokish/files/digest-blokish-0.9.4
new file mode 100644
index 000000000000..bff32bc29e94
--- /dev/null
+++ b/games-board/blokish/files/digest-blokish-0.9.4
@@ -0,0 +1,3 @@
+MD5 d66383243a21dba9b9aa312ebd41cd8a blokish_v0.9.4.tgz 165215
+RMD160 5c748485e75cc86711f6fbcb0d9678abbb1ec0f8 blokish_v0.9.4.tgz 165215
+SHA256 9ce9f6bf747df73b7827c37d4ecb24e10bdf491380bc8f9df3e32f45252bd54d blokish_v0.9.4.tgz 165215