summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/snipes/snipes-1.0.1.ebuild')
-rw-r--r--games-action/snipes/snipes-1.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-action/snipes/snipes-1.0.1.ebuild b/games-action/snipes/snipes-1.0.1.ebuild
new file mode 100644
index 000000000000..03dd1f4ead18
--- /dev/null
+++ b/games-action/snipes/snipes-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/snipes/snipes-1.0.1.ebuild,v 1.1 2005/02/06 08:53:48 vapier Exp $
+
+inherit games toolchain-funcs flag-o-matic
+
+DESCRIPTION="2D scrolling shooter, resembles old DOS game of same name"
+HOMEPAGE="http://geocities.com/fnorddaemon/"
+SRC_URI="http://geocities.com/fnorddaemon/snipes-1.0.1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=media-libs/libsdl-1.2.0"
+
+src_compile() {
+ export CC=$(tc-getCC)
+ append-flags $(sdl-config --cflags)
+ append-ldflags $(sdl-config --libs)
+
+ emake bin2h || die "bin2h failed"
+ ./bitms.sh || die "./bitms.sh failed"
+ emake snipes || die "snipes failed"
+}
+
+src_install() {
+ dogamesbin snipes || die "dogamesbin failed"
+ doman snipes.6
+}