summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/minetest/files/minetest-0.4.9-as-needed.patch')
-rw-r--r--games-action/minetest/files/minetest-0.4.9-as-needed.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-action/minetest/files/minetest-0.4.9-as-needed.patch b/games-action/minetest/files/minetest-0.4.9-as-needed.patch
new file mode 100644
index 000000000000..803ea0284827
--- /dev/null
+++ b/games-action/minetest/files/minetest-0.4.9-as-needed.patch
@@ -0,0 +1,35 @@
+commit a88bfd5b77fa0b5c60e438c0011dbdcee5e14dfd
+Author: hasufell <hasufell@gentoo.org>
+Date: Mon Nov 25 00:28:55 2013 +0100
+
+ CMAKE: fix linking order
+
+ this also fixes linking with as-needed wrt
+ https://github.com/minetest/minetest/issues/617
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index a1fee7a..a72bd4a 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -427,18 +427,18 @@ if(BUILD_CLIENT)
+ target_link_libraries(
+ ${PROJECT_NAME}
+ ${ZLIB_LIBRARIES}
+- ${IRRLICHT_LIBRARY}
++ ${X11_LIBRARIES}
+ ${OPENGL_LIBRARIES}
++ ${OPENGLES2_LIBRARIES}
+ ${JPEG_LIBRARIES}
+ ${BZIP2_LIBRARIES}
+ ${PNG_LIBRARIES}
+- ${X11_LIBRARIES}
++ ${IRRLICHT_LIBRARY}
+ ${GETTEXT_LIBRARY}
+ ${SOUND_LIBRARIES}
+ ${SQLITE3_LIBRARY}
+ ${LUA_LIBRARY}
+ ${JSON_LIBRARY}
+- ${OPENGLES2_LIBRARIES}
+ ${PLATFORM_LIBS}
+ ${CLIENT_PLATFORM_LIBS}
+ )