summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'eclass/kde4-meta.eclass')
-rw-r--r--eclass/kde4-meta.eclass17
1 files changed, 10 insertions, 7 deletions
diff --git a/eclass/kde4-meta.eclass b/eclass/kde4-meta.eclass
index f1c7564e5953..997c6de0d21e 100644
--- a/eclass/kde4-meta.eclass
+++ b/eclass/kde4-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.75 2014/02/06 17:07:56 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.76 2014/04/17 18:16:54 kensington Exp $
#
# @ECLASS: kde4-meta.eclass
# @MAINTAINER:
@@ -17,7 +17,7 @@ ___ECLASS_ONCE_KDE4_META="recur -_+^+_- spank"
[[ -z ${KMNAME} ]] && die "kde4-meta.eclass inherited but KMNAME not defined - broken ebuild"
-inherit kde4-base versionator
+inherit kde4-base
KDEMETA_EXPF="pkg_setup src_unpack src_prepare src_configure src_compile src_test src_install pkg_preinst pkg_postinst pkg_postrm"
EXPORT_FUNCTIONS ${KDEMETA_EXPF}
@@ -130,7 +130,7 @@ kde4-meta_src_unpack() {
subversion_bootstrap
;;
git)
- git-2_src_unpack
+ git-r3_src_unpack
;;
esac
fi
@@ -365,7 +365,7 @@ __list_needed_subdirectories() {
# @DESCRIPTION:
# Meta-package build system configuration handling - commenting out targets, etc..
kde4-meta_src_prepare() {
- debug-print-function ${FUNCNAME} "$@"
+ debug-print-function ${FUNCNAME} "$@"
kde4-meta_change_cmakelists
kde4-base_src_prepare
@@ -444,7 +444,7 @@ kde4-meta_change_cmakelists() {
-e 's/^#DONOTCOMPILE //g' \
-e '/install(.*)/I{s/^/#DONOTINSTALL /;}' \
-e '/^install(/,/)/I{s/^/#DONOTINSTALL /;}' \
- -e '/kde4_install_icons(.*)/{s/^/#DONOTINSTALL /;}' || \
+ -e '/kde4_install_icons(.*)/I{s/^/#DONOTINSTALL /;}' || \
die "${LINENO}: sed died in the KMCOMPILEONLY section while processing ${i}"
_change_cmakelists_parent_dirs ${i}
done
@@ -503,6 +503,9 @@ kde4-meta_change_cmakelists() {
fi
;;
kde-runtime)
+ sed -e 's/TYPE REQUIRED/TYPE OPTIONAL/' -e '/LibGcrypt/s/REQUIRED//' -i CMakeLists.txt \
+ || die "${LINENO}: sed died in kde-runtime dep reduction section"
+
# COLLISION PROTECT section
# Only install the kde4 script as part of kde-base/kdebase-data
if [[ ${PN} != kdebase-data && -f CMakeLists.txt ]]; then
@@ -572,7 +575,7 @@ kde4-meta_src_compile() {
# Currently just calls its equivalent in kde4-base.eclass(5) if
# I_KNOW_WHAT_I_AM_DOING is set. Use this in split ebuilds.
kde4-meta_src_test() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
if [[ $I_KNOW_WHAT_I_AM_DOING ]]; then
kde4-base_src_test
@@ -585,7 +588,7 @@ kde4-meta_src_test() {
# @DESCRIPTION:
# Function for installing KDE4 split applications.
kde4-meta_src_install() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
# Search ${S}/${KMMODULE} and install common documentation files found
local doc