summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mcvs/ChangeLog41
-rw-r--r--dev-vcs/mcvs/files/1.0.13-gentoo.patch12
-rw-r--r--dev-vcs/mcvs/mcvs-1.0.10.ebuild33
-rw-r--r--dev-vcs/mcvs/mcvs-1.0.13.ebuild34
-rw-r--r--dev-vcs/mcvs/metadata.xml19
5 files changed, 139 insertions, 0 deletions
diff --git a/dev-vcs/mcvs/ChangeLog b/dev-vcs/mcvs/ChangeLog
new file mode 100644
index 000000000000..c7851213ff23
--- /dev/null
+++ b/dev-vcs/mcvs/ChangeLog
@@ -0,0 +1,41 @@
+# ChangeLog for dev-vcs/mcvs
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mcvs/ChangeLog,v 1.1 2010/03/05 16:22:49 ulm Exp $
+
+ 05 Mar 2010; Ulrich Mueller <ulm@gentoo.org> +files/1.0.13-gentoo.patch,
+ +mcvs-1.0.10.ebuild, +mcvs-1.0.13.ebuild, +metadata.xml:
+ Move package from dev-util to dev-vcs; update dependency on dev-vcs/rcs;
+ bug 56967.
+
+ 19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
+ Remove mkennedy from metadata.xml due to retirement.
+
+ 22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
+ Transition to Manifest2.
+
+ 16 Feb 2006; Matthew Kennedy <mkennedy@gentoo.org> metadata.xml:
+ Rename listed herd from lisp to common-lisp; See Bug #94878.
+
+ 07 May 2005; David Holm <dholm@gentoo.org> mcvs-1.0.13.ebuild:
+ Added to ~ppc.
+
+ 08 Jun 2004; <mkennedy@gentoo.org> mcvs-1.0.13.ebuild:
+ Marking stable x86
+
+*mcvs-1.0.13 (08 Jun 2004)
+
+ 08 Jun 2004; <mkennedy@gentoo.org> +files/1.0.13-gentoo.patch,
+ +mcvs-1.0.13.ebuild:
+ New upstream version; Resolves Bug #53212.
+
+ 18 Mar 2004; <mkennedy@gentoo.org> mcvs-1.0.10.ebuild:
+ Added missing app-text/rcs dependency
+
+ 26 Jan 2004; <mkennedy@gentoo.org> mcvs-1.0.10.ebuild:
+ Added missing dev-util/cvs dependency
+
+*mcvs-1.0.10 (26 Jan 2004)
+
+ 26 Jan 2004; <mkennedy@gentoo.org> mcvs-1.0.10.ebuild, metadata.xml:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+ based on the Debian Project port of the same name.
diff --git a/dev-vcs/mcvs/files/1.0.13-gentoo.patch b/dev-vcs/mcvs/files/1.0.13-gentoo.patch
new file mode 100644
index 000000000000..cd3f3db6f6c5
--- /dev/null
+++ b/dev-vcs/mcvs/files/1.0.13-gentoo.patch
@@ -0,0 +1,12 @@
+diff -ur mcvs-1.0.13.orig/code/unix-bindings/unix.lisp mcvs-1.0.13/code/unix-bindings/unix.lisp
+--- mcvs-1.0.13.orig/code/unix-bindings/unix.lisp 2004-06-08 02:28:51.393937000 -0500
++++ mcvs-1.0.13/code/unix-bindings/unix.lisp 2004-06-08 02:40:31.521501480 -0500
+@@ -38,7 +38,7 @@
+ (defmacro def-c-call-out (sym &body args)
+ `(def-call-out ,sym (:language :stdc) ,@args))
+
+-#.(when (> (read-from-string (lisp-implementation-version)) 2.30)
++#.(progn
+ (push :clisp-newer-than-2.30 *features*)
+ (values))
+
diff --git a/dev-vcs/mcvs/mcvs-1.0.10.ebuild b/dev-vcs/mcvs/mcvs-1.0.10.ebuild
new file mode 100644
index 000000000000..3129e2391d99
--- /dev/null
+++ b/dev-vcs/mcvs/mcvs-1.0.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mcvs/mcvs-1.0.10.ebuild,v 1.1 2010/03/05 16:22:49 ulm Exp $
+
+inherit common-lisp-common eutils
+
+DEB_PV=3
+
+DESCRIPTION="Meta-CVS is a version control system built around CVS."
+HOMEPAGE="http://users.footprints.net/~kaz/mcvs.html"
+SRC_URI="http://users.footprints.net/~kaz/${P}.tar.gz
+ mirror://debian/pool/main/m/mcvs/mcvs_${PV}-${DEB_PV}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lisp/clisp-2.32
+ dev-util/cvs
+ dev-vcs/rcs"
+
+src_unpack() {
+ unpack ${A}
+ epatch mcvs_${PV}-${DEB_PV}.diff
+}
+
+src_install() {
+ doman debian/mcvs.5
+ dodoc ChangeLog QUICK-GUIDE RELEASE-NOTES TODO UPGRADE-EXISTING
+ do-debian-credits
+ cd code && ./install.sh /usr "${D}"
+}
diff --git a/dev-vcs/mcvs/mcvs-1.0.13.ebuild b/dev-vcs/mcvs/mcvs-1.0.13.ebuild
new file mode 100644
index 000000000000..db6422fee51b
--- /dev/null
+++ b/dev-vcs/mcvs/mcvs-1.0.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mcvs/mcvs-1.0.13.ebuild,v 1.1 2010/03/05 16:22:49 ulm Exp $
+
+inherit common-lisp-common eutils
+
+DEB_PV=2
+
+DESCRIPTION="Meta-CVS is a version control system built around CVS."
+HOMEPAGE="http://users.footprints.net/~kaz/mcvs.html"
+SRC_URI="http://users.footprints.net/~kaz/${P}.tar.gz
+ mirror://debian/pool/main/m/mcvs/mcvs_${PV}-${DEB_PV}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-lisp/clisp-2.32
+ dev-util/cvs
+ dev-vcs/rcs"
+
+src_unpack() {
+ unpack ${A}
+ epatch mcvs_${PV}-${DEB_PV}.diff
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+}
+
+src_install() {
+ doman debian/mcvs.1
+ dodoc ChangeLog QUICK-GUIDE RELEASE-NOTES TODO UPGRADE-EXISTING
+ do-debian-credits
+ cd code && ./install.sh /usr "${D}"
+}
diff --git a/dev-vcs/mcvs/metadata.xml b/dev-vcs/mcvs/metadata.xml
new file mode 100644
index 000000000000..88ecd38c3946
--- /dev/null
+++ b/dev-vcs/mcvs/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+Meta-CVS is a version control system built around CVS. Although it
+retains most of the features of CVS, including all of the networking
+support, it is more capable than CVS, and easier to use. Its main
+features are:
+
+ * Directory structure versioning
+ * User-friendly file type handling
+ * Sane corner cases
+ * Simple branching and merging
+ * Support for symbolic links and meta-data
+ * Tracking of third party code containing moves and renames
+ * Ease of deployment
+</longdescription>
+</pkgmetadata>