summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/ChangeLog5
-rw-r--r--dev-vcs/git/git-1.7.10.2.ebuild14
-rw-r--r--dev-vcs/git/git-1.7.10.ebuild14
3 files changed, 9 insertions, 24 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index 4f9520e10cf4..67a519660900 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.133 2012/06/14 04:53:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.134 2012/06/14 04:55:53 vapier Exp $
14 Jun 2012; Mike Frysinger <vapier@gentoo.org> git-1.7.9.1.ebuild,
git-1.7.9.2.ebuild, git-1.7.9.3.ebuild, git-1.7.9.4.ebuild,
@@ -11,7 +11,8 @@
git-1.7.8.2.ebuild, git-1.7.8.3.ebuild, git-1.7.8.4.ebuild,
git-1.7.8.5.ebuild, git-1.7.8.6.ebuild, git-1.7.8.ebuild, git-1.7.9.1.ebuild,
git-1.7.9.2.ebuild, git-1.7.9.3.ebuild, git-1.7.9.4.ebuild,
- git-1.7.9.7.ebuild, git-1.7.9.ebuild, git-1.7.9_rc2.ebuild, git-9999.ebuild:
+ git-1.7.9.7.ebuild, git-1.7.9.ebuild, git-1.7.9_rc2.ebuild,
+ git-1.7.10.ebuild, git-1.7.10.2.ebuild, git-9999.ebuild:
Re-enable USE=-iconv support now that the bug originally disabling it was
fixed in upstream, and make sure we default to USE=iconv so that
unicode/etc... messages "just work" out of the box #355467 by Tom Lloyd.
diff --git a/dev-vcs/git/git-1.7.10.2.ebuild b/dev-vcs/git/git-1.7.10.2.ebuild
index 4f66fa57fe11..1a152d984981 100644
--- a/dev-vcs/git/git-1.7.10.2.ebuild
+++ b/dev-vcs/git/git-1.7.10.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.10.2.ebuild,v 1.1 2012/05/20 04:25:24 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.10.2.ebuild,v 1.2 2012/06/14 04:55:53 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -144,11 +144,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use pcre \
@@ -221,10 +217,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream
diff --git a/dev-vcs/git/git-1.7.10.ebuild b/dev-vcs/git/git-1.7.10.ebuild
index 257850c53a6d..12e81a219a68 100644
--- a/dev-vcs/git/git-1.7.10.ebuild
+++ b/dev-vcs/git/git-1.7.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.10.ebuild,v 1.2 2012/04/23 17:21:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.10.ebuild,v 1.3 2012/06/14 04:55:53 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -144,11 +144,7 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
use iconv \
- || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
- # || myopts="${myopts} NO_ICONV=YesPlease"
- # because, above, we need to do this unconditionally (no "&& use iconv")
- use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
-
+ || myopts="${myopts} NO_ICONV=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use pcre \
@@ -221,10 +217,6 @@ src_prepare() {
# Merged in 1.7.5.x
#epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
- # USE=-iconv causes segfaults, fixed post 1.7.1
- # Gentoo bug #321895
- #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
-
# Fix false positives with t3404 due to SHELL=/bin/false for the portage
# user.
# Merged upstream