summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/ChangeLog6
-rw-r--r--dev-vcs/mercurial/mercurial-1.7.ebuild132
-rw-r--r--dev-vcs/mercurial/mercurial-2.0.1.ebuild139
-rw-r--r--dev-vcs/mercurial/mercurial-2.0.2.ebuild139
-rw-r--r--dev-vcs/mercurial/mercurial-2.1.ebuild139
5 files changed, 5 insertions, 550 deletions
diff --git a/dev-vcs/mercurial/ChangeLog b/dev-vcs/mercurial/ChangeLog
index 7e635e049b9f..e57a2e2baf69 100644
--- a/dev-vcs/mercurial/ChangeLog
+++ b/dev-vcs/mercurial/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/mercurial
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.72 2012/05/02 08:35:56 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.73 2012/05/02 08:38:20 djc Exp $
+
+ 02 May 2012; Dirkjan Ochtman <djc@gentoo.org> -mercurial-1.7.ebuild,
+ -mercurial-2.0.1.ebuild, -mercurial-2.0.2.ebuild, -mercurial-2.1.ebuild:
+ Remove old versions.
*mercurial-2.2 (02 May 2012)
diff --git a/dev-vcs/mercurial/mercurial-1.7.ebuild b/dev-vcs/mercurial/mercurial-1.7.ebuild
deleted file mode 100644
index 3ef47e716536..000000000000
--- a/dev-vcs/mercurial/mercurial-1.7.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-1.7.ebuild,v 1.11 2012/02/21 03:31:01 patrick Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="threads"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit bash-completion elisp-common eutils distutils
-
-DESCRIPTION="Scalable distributed SCM"
-HOMEPAGE="http://mercurial.selenic.com/"
-SRC_URI="http://mercurial.selenic.com/release/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bugzilla emacs gpg test tk zsh-completion"
-
-RDEPEND="bugzilla? ( dev-python/mysql-python )
- gpg? ( app-crypt/gnupg )
- tk? ( dev-lang/tk )
- zsh-completion? ( app-shells/zsh )"
-DEPEND="emacs? ( virtual/emacs )
- test? ( app-arch/unzip
- dev-python/pygments )"
-
-PYTHON_CFLAGS=(
- "2.* + -fno-strict-aliasing"
- "* - -ftracer -ftree-vectorize"
-)
-
-PYTHON_MODNAME="${PN} hgext"
-SITEFILE="70${PN}-gentoo.el"
-
-src_compile() {
- distutils_src_compile
-
- if use emacs; then
- cd "${S}"/contrib
- elisp-compile mercurial.el || die "elisp-compile failed!"
- fi
-
- rm -rf contrib/{win32,macosx}
-}
-
-src_install() {
- distutils_src_install
-
- dobashcompletion contrib/bash_completion ${PN}
-
- if use zsh-completion ; then
- insinto /usr/share/zsh/site-functions
- newins contrib/zsh_completion _hg
- fi
-
- rm -f doc/*.?.txt
- dodoc CONTRIBUTORS PKG-INFO README doc/*.txt
- cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/
-
- dobin hgeditor
- dobin contrib/hgk
- dobin contrib/hg-ssh
-
- rm -f contrib/hgk contrib/hg-ssh
-
- rm -f contrib/bash_completion
- cp -r contrib "${ED}"/usr/share/doc/${PF}/
- doman doc/*.?
-
- cat > "${T}/80mercurial" <<-EOF
-HG="${EPREFIX}/usr/bin/hg"
-EOF
- doenvd "${T}/80mercurial"
-
- if use emacs; then
- elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- fi
-}
-
-src_test() {
- cd "${S}/tests/"
- rm -rf *svn* # Subversion tests fail with 1.5
- rm -f test-archive # Fails due to verbose tar output changes
- rm -f test-convert-baz* # GNU Arch baz
- rm -f test-convert-cvs* # CVS
- rm -f test-convert-darcs* # Darcs
- rm -f test-convert-git* # git
- rm -f test-convert-mtn* # monotone
- rm -f test-convert-tla* # GNU Arch tla
- rm -f test-doctest* # doctest always fails with python 2.5.x
- if [[ ${EUID} -eq 0 ]]; then
- einfo "Removing tests which require user privileges to succeed"
- rm -f test-command-template # Test is broken when run as root
- rm -f test-convert # Test is broken when run as root
- rm -f test-lock-badness # Test is broken when run as root
- rm -f test-permissions # Test is broken when run as root
- rm -f test-pull-permission # Test is broken when run as root
- rm -f test-clone-failure
- rm -f test-journal-exists
- rm -f test-repair-strip
- fi
-
- testing() {
- local testdir="${T}/tests-${PYTHON_ABI}"
- rm -rf "${testdir}"
- "$(PYTHON)" run-tests.py --tmpdir="${testdir}"
- }
- python_execute_function testing
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- use emacs && elisp-site-regen
- bash-completion_pkg_postinst
-
- elog "If you want to convert repositories from other tools using convert"
- elog "extension please install correct tool:"
- elog " dev-vcs/cvs"
- elog " dev-vcs/darcs"
- elog " dev-vcs/git"
- elog " dev-vcs/monotone"
- elog " dev-vcs/subversion"
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- use emacs && elisp-site-regen
-}
diff --git a/dev-vcs/mercurial/mercurial-2.0.1.ebuild b/dev-vcs/mercurial/mercurial-2.0.1.ebuild
deleted file mode 100644
index 94896cac19c5..000000000000
--- a/dev-vcs/mercurial/mercurial-2.0.1.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-2.0.1.ebuild,v 1.3 2012/02/21 03:31:01 patrick Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="threads"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit bash-completion-r1 elisp-common eutils distutils
-
-DESCRIPTION="Scalable distributed SCM"
-HOMEPAGE="http://mercurial.selenic.com/"
-SRC_URI="http://mercurial.selenic.com/release/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bugzilla emacs gpg test tk zsh-completion"
-
-RDEPEND="bugzilla? ( dev-python/mysql-python )
- gpg? ( app-crypt/gnupg )
- tk? ( dev-lang/tk )
- zsh-completion? ( app-shells/zsh )"
-DEPEND="emacs? ( virtual/emacs )
- test? ( app-arch/unzip
- dev-python/pygments )"
-
-PYTHON_CFLAGS=(
- "2.* + -fno-strict-aliasing"
- "* - -ftracer -ftree-vectorize"
-)
-
-PYTHON_MODNAME="${PN} hgext"
-SITEFILE="70${PN}-gentoo.el"
-
-src_prepare() {
- distutils_src_prepare
-
- # fix up logic that won't work in Gentoo Prefix (also won't outside in
- # certain cases), bug #362891
- sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
-}
-
-src_compile() {
- distutils_src_compile
-
- if use emacs; then
- cd "${S}"/contrib || die
- elisp-compile mercurial.el || die "elisp-compile failed!"
- fi
-
- rm -rf contrib/{win32,macosx} || die
-}
-
-src_install() {
- distutils_src_install
-
- newbashcomp contrib/bash_completion ${PN} || die
-
- if use zsh-completion ; then
- insinto /usr/share/zsh/site-functions
- newins contrib/zsh_completion _hg || die
- fi
-
- rm -f doc/*.?.txt || die
- dodoc CONTRIBUTORS PKG-INFO README doc/*.txt || die
- cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
-
- dobin hgeditor || die
- dobin contrib/hgk || die
- dobin contrib/hg-ssh || die
-
- rm -f contrib/hgk contrib/hg-ssh || die
-
- rm -f contrib/bash_completion || die
- cp -r contrib "${ED}"/usr/share/doc/${PF}/ || die
- doman doc/*.? || die
-
- cat > "${T}/80mercurial" <<-EOF
-HG="${EPREFIX}/usr/bin/hg"
-EOF
- doenvd "${T}/80mercurial" || die
-
- if use emacs; then
- elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- fi
-}
-
-src_test() {
- cd "${S}/tests/" || die
- rm -rf *svn* || die # Subversion tests fail with 1.5
- rm -f test-archive || die # Fails due to verbose tar output changes
- rm -f test-convert-baz* || die # GNU Arch baz
- rm -f test-convert-cvs* || die # CVS
- rm -f test-convert-darcs* || die # Darcs
- rm -f test-convert-git* || die # git
- rm -f test-convert-mtn* || die # monotone
- rm -f test-convert-tla* || die # GNU Arch tla
- rm -f test-doctest* || die # doctest always fails with python 2.5.x
- if [[ ${EUID} -eq 0 ]]; then
- einfo "Removing tests which require user privileges to succeed"
- rm -f test-command-template || die # Test is broken when run as root
- rm -f test-convert || die # Test is broken when run as root
- rm -f test-lock-badness || die # Test is broken when run as root
- rm -f test-permissions || die # Test is broken when run as root
- rm -f test-pull-permission || die # Test is broken when run as root
- rm -f test-clone-failure || die
- rm -f test-journal-exists || die
- rm -f test-repair-strip || die
- fi
-
- testing() {
- local testdir="${T}/tests-${PYTHON_ABI}"
- rm -rf "${testdir}" || die
- "$(PYTHON)" run-tests.py --tmpdir="${testdir}"
- }
- python_execute_function testing
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- use emacs && elisp-site-regen
-
- elog "If you want to convert repositories from other tools using convert"
- elog "extension please install correct tool:"
- elog " dev-vcs/cvs"
- elog " dev-vcs/darcs"
- elog " dev-vcs/git"
- elog " dev-vcs/monotone"
- elog " dev-vcs/subversion"
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- use emacs && elisp-site-regen
-}
diff --git a/dev-vcs/mercurial/mercurial-2.0.2.ebuild b/dev-vcs/mercurial/mercurial-2.0.2.ebuild
deleted file mode 100644
index 9b8918086b1b..000000000000
--- a/dev-vcs/mercurial/mercurial-2.0.2.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-2.0.2.ebuild,v 1.2 2012/02/21 03:31:01 patrick Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="threads"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit bash-completion-r1 elisp-common eutils distutils
-
-DESCRIPTION="Scalable distributed SCM"
-HOMEPAGE="http://mercurial.selenic.com/"
-SRC_URI="http://mercurial.selenic.com/release/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bugzilla emacs gpg test tk zsh-completion"
-
-RDEPEND="bugzilla? ( dev-python/mysql-python )
- gpg? ( app-crypt/gnupg )
- tk? ( dev-lang/tk )
- zsh-completion? ( app-shells/zsh )"
-DEPEND="emacs? ( virtual/emacs )
- test? ( app-arch/unzip
- dev-python/pygments )"
-
-PYTHON_CFLAGS=(
- "2.* + -fno-strict-aliasing"
- "* - -ftracer -ftree-vectorize"
-)
-
-PYTHON_MODNAME="${PN} hgext"
-SITEFILE="70${PN}-gentoo.el"
-
-src_prepare() {
- distutils_src_prepare
-
- # fix up logic that won't work in Gentoo Prefix (also won't outside in
- # certain cases), bug #362891
- sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
-}
-
-src_compile() {
- distutils_src_compile
-
- if use emacs; then
- cd "${S}"/contrib || die
- elisp-compile mercurial.el || die "elisp-compile failed!"
- fi
-
- rm -rf contrib/{win32,macosx} || die
-}
-
-src_install() {
- distutils_src_install
-
- newbashcomp contrib/bash_completion ${PN} || die
-
- if use zsh-completion ; then
- insinto /usr/share/zsh/site-functions
- newins contrib/zsh_completion _hg || die
- fi
-
- rm -f doc/*.?.txt || die
- dodoc CONTRIBUTORS PKG-INFO README doc/*.txt || die
- cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
-
- dobin hgeditor || die
- dobin contrib/hgk || die
- dobin contrib/hg-ssh || die
-
- rm -f contrib/hgk contrib/hg-ssh || die
-
- rm -f contrib/bash_completion || die
- cp -r contrib "${ED}"/usr/share/doc/${PF}/ || die
- doman doc/*.? || die
-
- cat > "${T}/80mercurial" <<-EOF
-HG="${EPREFIX}/usr/bin/hg"
-EOF
- doenvd "${T}/80mercurial" || die
-
- if use emacs; then
- elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- fi
-}
-
-src_test() {
- cd "${S}/tests/" || die
- rm -rf *svn* || die # Subversion tests fail with 1.5
- rm -f test-archive || die # Fails due to verbose tar output changes
- rm -f test-convert-baz* || die # GNU Arch baz
- rm -f test-convert-cvs* || die # CVS
- rm -f test-convert-darcs* || die # Darcs
- rm -f test-convert-git* || die # git
- rm -f test-convert-mtn* || die # monotone
- rm -f test-convert-tla* || die # GNU Arch tla
- rm -f test-doctest* || die # doctest always fails with python 2.5.x
- if [[ ${EUID} -eq 0 ]]; then
- einfo "Removing tests which require user privileges to succeed"
- rm -f test-command-template || die # Test is broken when run as root
- rm -f test-convert || die # Test is broken when run as root
- rm -f test-lock-badness || die # Test is broken when run as root
- rm -f test-permissions || die # Test is broken when run as root
- rm -f test-pull-permission || die # Test is broken when run as root
- rm -f test-clone-failure || die
- rm -f test-journal-exists || die
- rm -f test-repair-strip || die
- fi
-
- testing() {
- local testdir="${T}/tests-${PYTHON_ABI}"
- rm -rf "${testdir}" || die
- "$(PYTHON)" run-tests.py --tmpdir="${testdir}"
- }
- python_execute_function testing
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- use emacs && elisp-site-regen
-
- elog "If you want to convert repositories from other tools using convert"
- elog "extension please install correct tool:"
- elog " dev-vcs/cvs"
- elog " dev-vcs/darcs"
- elog " dev-vcs/git"
- elog " dev-vcs/monotone"
- elog " dev-vcs/subversion"
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- use emacs && elisp-site-regen
-}
diff --git a/dev-vcs/mercurial/mercurial-2.1.ebuild b/dev-vcs/mercurial/mercurial-2.1.ebuild
deleted file mode 100644
index cdc99fefe2e9..000000000000
--- a/dev-vcs/mercurial/mercurial-2.1.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-2.1.ebuild,v 1.2 2012/02/21 03:31:01 patrick Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="threads"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit bash-completion-r1 elisp-common eutils distutils
-
-DESCRIPTION="Scalable distributed SCM"
-HOMEPAGE="http://mercurial.selenic.com/"
-SRC_URI="http://mercurial.selenic.com/release/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bugzilla emacs gpg test tk zsh-completion"
-
-RDEPEND="bugzilla? ( dev-python/mysql-python )
- gpg? ( app-crypt/gnupg )
- tk? ( dev-lang/tk )
- zsh-completion? ( app-shells/zsh )"
-DEPEND="emacs? ( virtual/emacs )
- test? ( app-arch/unzip
- dev-python/pygments )"
-
-PYTHON_CFLAGS=(
- "2.* + -fno-strict-aliasing"
- "* - -ftracer -ftree-vectorize"
-)
-
-PYTHON_MODNAME="${PN} hgext"
-SITEFILE="70${PN}-gentoo.el"
-
-src_prepare() {
- distutils_src_prepare
-
- # fix up logic that won't work in Gentoo Prefix (also won't outside in
- # certain cases), bug #362891
- sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
-}
-
-src_compile() {
- distutils_src_compile
-
- if use emacs; then
- cd "${S}"/contrib || die
- elisp-compile mercurial.el || die "elisp-compile failed!"
- fi
-
- rm -rf contrib/{win32,macosx} || die
-}
-
-src_install() {
- distutils_src_install
-
- newbashcomp contrib/bash_completion ${PN} || die
-
- if use zsh-completion ; then
- insinto /usr/share/zsh/site-functions
- newins contrib/zsh_completion _hg || die
- fi
-
- rm -f doc/*.?.txt || die
- dodoc CONTRIBUTORS PKG-INFO README doc/*.txt || die
- cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
-
- dobin hgeditor || die
- dobin contrib/hgk || die
- dobin contrib/hg-ssh || die
-
- rm -f contrib/hgk contrib/hg-ssh || die
-
- rm -f contrib/bash_completion || die
- cp -r contrib "${ED}"/usr/share/doc/${PF}/ || die
- doman doc/*.? || die
-
- cat > "${T}/80mercurial" <<-EOF
-HG="${EPREFIX}/usr/bin/hg"
-EOF
- doenvd "${T}/80mercurial" || die
-
- if use emacs; then
- elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- fi
-}
-
-src_test() {
- cd "${S}/tests/" || die
- rm -rf *svn* || die # Subversion tests fail with 1.5
- rm -f test-archive || die # Fails due to verbose tar output changes
- rm -f test-convert-baz* || die # GNU Arch baz
- rm -f test-convert-cvs* || die # CVS
- rm -f test-convert-darcs* || die # Darcs
- rm -f test-convert-git* || die # git
- rm -f test-convert-mtn* || die # monotone
- rm -f test-convert-tla* || die # GNU Arch tla
- rm -f test-doctest* || die # doctest always fails with python 2.5.x
- if [[ ${EUID} -eq 0 ]]; then
- einfo "Removing tests which require user privileges to succeed"
- rm -f test-command-template || die # Test is broken when run as root
- rm -f test-convert || die # Test is broken when run as root
- rm -f test-lock-badness || die # Test is broken when run as root
- rm -f test-permissions || die # Test is broken when run as root
- rm -f test-pull-permission || die # Test is broken when run as root
- rm -f test-clone-failure || die
- rm -f test-journal-exists || die
- rm -f test-repair-strip || die
- fi
-
- testing() {
- local testdir="${T}/tests-${PYTHON_ABI}"
- rm -rf "${testdir}" || die
- "$(PYTHON)" run-tests.py --tmpdir="${testdir}"
- }
- python_execute_function testing
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- use emacs && elisp-site-regen
-
- elog "If you want to convert repositories from other tools using convert"
- elog "extension please install correct tool:"
- elog " dev-vcs/cvs"
- elog " dev-vcs/darcs"
- elog " dev-vcs/git"
- elog " dev-vcs/monotone"
- elog " dev-vcs/subversion"
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- use emacs && elisp-site-regen
-}