summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mono-debugger/ChangeLog8
-rw-r--r--dev-util/mono-debugger/files/mono-debugger-2.8-system-bfd.patch96
-rw-r--r--dev-util/mono-debugger/mono-debugger-2.8.ebuild49
3 files changed, 152 insertions, 1 deletions
diff --git a/dev-util/mono-debugger/ChangeLog b/dev-util/mono-debugger/ChangeLog
index 396b4287ca12..6a2471ec21dc 100644
--- a/dev-util/mono-debugger/ChangeLog
+++ b/dev-util/mono-debugger/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/mono-debugger
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/ChangeLog,v 1.41 2010/10/07 20:18:43 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/ChangeLog,v 1.42 2010/10/09 20:05:25 ali_bush Exp $
+
+*mono-debugger-2.8 (09 Oct 2010)
+
+ 09 Oct 2010; Alistair Bush <ali_bush@gentoo.org>
+ +mono-debugger-2.8.ebuild, +files/mono-debugger-2.8-system-bfd.patch:
+ Version Bump
07 Oct 2010; Pacho Ramos <pacho@gentoo.org> -mono-debugger-2.0.ebuild,
-mono-debugger-2.0.9999.ebuild, -mono-debugger-2.4.2.ebuild,
diff --git a/dev-util/mono-debugger/files/mono-debugger-2.8-system-bfd.patch b/dev-util/mono-debugger/files/mono-debugger-2.8-system-bfd.patch
new file mode 100644
index 000000000000..44804bd10747
--- /dev/null
+++ b/dev-util/mono-debugger/files/mono-debugger-2.8-system-bfd.patch
@@ -0,0 +1,96 @@
+diff --git a/configure.in b/configure.in
+index c643e64..402be56 100644
+--- a/configure.in
++++ b/configure.in
+@@ -64,6 +64,18 @@ case "$host" in
+ esac
+ AC_MSG_RESULT(ok)
+
++AC_ARG_WITH([system-libbfd],
++ AS_HELP_STRING([--with-system-libbfd], [Use the system copy of libbfd and libopcodes.]))
++
++AS_IF([test "x$with_system_libbfd" = "xyes"],
++ [
++ AC_CHECK_HEADERS([bfd.h], [], [AC_MSG_ERROR([Missing bfd.h header])])
++ AC_CHECK_LIB([bfd], [bfd_init], [:], [AC_MSG_ERROR([Missing libbfd library])])
++ AC_CHECK_LIB([opcodes], [init_disassemble_info], [:], [AC_MSG_ERROR([Missing libopcodes library])])
++ ])
++
++AM_CONDITIONAL([SYSTEM_LIBBFD], [test "x$with_system_libbfd" = "xyes"])
++
+ AC_ARG_WITH(bfd-target,
+ [ --with-bfd-target Manually override the BFD target],
+ if test x$with_bfd_target != "x"; then
+diff --git a/sysdeps/Makefile.am b/sysdeps/Makefile.am
+index 017026f..f63c181 100644
+--- a/sysdeps/Makefile.am
++++ b/sysdeps/Makefile.am
+@@ -1 +1,5 @@
++if !SYSTEM_LIBBFD
+ SUBDIRS = bfd server
++else
++SUBDIRS = server
++endif
+diff --git a/sysdeps/server/Makefile.am b/sysdeps/server/Makefile.am
+index dad57ab..8e7ac68 100644
+--- a/sysdeps/server/Makefile.am
++++ b/sysdeps/server/Makefile.am
+@@ -6,10 +6,9 @@ libmonodebuggerbfdglue_la_SOURCES = \
+ bfdglue.c \
+ bfdglue.h
+
++if !SYSTEM_LIBBFD
+ libmonodebuggerbfdglue_la_LIBADD = \
+ ../../sysdeps/bfd/opcodes/libopcodes.la ../../sysdeps/bfd/libbfd.la
+-libmonodebuggerbfdglue_la_LDFLAGS = \
+- -no-undefined -module -export-dynamic -shared
+
+ libmonodebuggerbfdglue_la_CPPFLAGS = \
+ -I$(top_srcdir)/sysdeps/bfd \
+@@ -17,6 +16,17 @@ libmonodebuggerbfdglue_la_CPPFLAGS = \
+ -I$(top_srcdir)/sysdeps/bfd/opcodes \
+ @SERVER_DEPENDENCIES_CFLAGS@ @server_cflags@
+
++else
++libmonodebuggerbfdglue_la_LIBADD =
++
++libmonodebuggerbfdglue_la_CPPFLAGS = -lopcodes -lbfd \
++ @SERVER_DEPENDENCIES_CFLAGS@ @server_cflags@
++
++endif
++
++libmonodebuggerbfdglue_la_LDFLAGS = \
++ -no-undefined -module -export-dynamic -shared
++
+ EXTRA_libmonodebuggerserver_la_SOURCES = \
+ i386-arch.c \
+ i386-arch.h \
+diff --git a/sysdeps/server/bfdglue.c b/sysdeps/server/bfdglue.c
+index 9a741ac..e2138e7 100644
+--- a/sysdeps/server/bfdglue.c
++++ b/sysdeps/server/bfdglue.c
+@@ -1,3 +1,5 @@
++#include <config.h>
++
+ #include <bfdglue.h>
+ #include <signal.h>
+ #include <string.h>
+@@ -246,7 +248,11 @@ bfd_glue_get_errormsg (void)
+ guint32
+ bfd_glue_get_section_size (asection *p)
+ {
++#ifdef HAVE_ASECTION_RAWSIZE
++ return p->rawsize ? p->rawsize : p->size;
++#else
+ return p->_raw_size;
++#endif
+ }
+
+ BfdGlueSectionFlags
+@@ -350,4 +356,4 @@ guint64
+ bfd_glue_get_start_address (bfd *abfd)
+ {
+ return bfd_get_start_address (abfd);
+-}
+\ No newline at end of file
++}
diff --git a/dev-util/mono-debugger/mono-debugger-2.8.ebuild b/dev-util/mono-debugger/mono-debugger-2.8.ebuild
new file mode 100644
index 000000000000..81d2c086a3f3
--- /dev/null
+++ b/dev-util/mono-debugger/mono-debugger-2.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/mono-debugger-2.8.ebuild,v 1.1 2010/10/09 20:05:25 ali_bush Exp $
+
+# bah, tests fail. Needs to be fixed ...
+RESTRICT="test"
+
+EAPI=2
+
+PATCHLEVEL=1
+
+inherit go-mono mono autotools flag-o-matic eutils
+
+DESCRIPTION="Debugger for .NET managed and unmanaged applications"
+HOMEPAGE="http://www.go-mono.com"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+#Bundles jay
+# Binutils is needed for libbfd
+RDEPEND="!!=dev-lang/mono-2.2
+ sys-devel/binutils
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ !dev-lang/mercury"
+
+src_prepare() {
+ go-mono_src_prepare
+
+ epatch "${FILESDIR}/${PN}-2.8-system-bfd.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ # Let's go for extra safety to avoid runtime errors, until
+ # upstream applies it.
+ append-ldflags -Wl,--no-undefined
+
+ go-mono_src_configure \
+ --disable-static
+}
+
+src_compile() {
+ emake -j1 || die "Failed to build"
+}