summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/google-perftools/ChangeLog12
-rw-r--r--dev-util/google-perftools/files/google-perftools-1.7-syntax.patch13
-rw-r--r--dev-util/google-perftools/google-perftools-1.10.ebuild (renamed from dev-util/google-perftools/google-perftools-1.6.ebuild)43
-rw-r--r--dev-util/google-perftools/google-perftools-2.0.ebuild (renamed from dev-util/google-perftools/google-perftools-1.7.ebuild)36
4 files changed, 52 insertions, 52 deletions
diff --git a/dev-util/google-perftools/ChangeLog b/dev-util/google-perftools/ChangeLog
index f66e0cf0819d..a7452d52aa5f 100644
--- a/dev-util/google-perftools/ChangeLog
+++ b/dev-util/google-perftools/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/google-perftools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/ChangeLog,v 1.17 2012/06/25 06:28:33 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/ChangeLog,v 1.18 2012/07/06 00:57:34 flameeyes Exp $
+
+*google-perftools-2.0 (06 Jul 2012)
+*google-perftools-1.10 (06 Jul 2012)
+
+ 06 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +google-perftools-1.10.ebuild, +google-perftools-2.0.ebuild,
+ -files/google-perftools-1.7-syntax.patch, -google-perftools-1.6.ebuild,
+ -google-perftools-1.7.ebuild:
+ Version bump (both 1.10 and 2.0, the latter masked). Remove old versions.
25 Jun 2012; Jeff Horelick <jdhore@gentoo.org> google-perftools-1.8.3.ebuild:
marked x86 per bug 418445
@@ -89,4 +98,3 @@
Initial import of google's perftools package, from Sven Wegener
(swegener)'s overlay, upon request by Pavel Stratil. Tests restricted as
per bug #290249.
-
diff --git a/dev-util/google-perftools/files/google-perftools-1.7-syntax.patch b/dev-util/google-perftools/files/google-perftools-1.7-syntax.patch
deleted file mode 100644
index c9226a98a625..000000000000
--- a/dev-util/google-perftools/files/google-perftools-1.7-syntax.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: google-perftools-1.7/src/google/malloc_hook_c.h
-===================================================================
---- google-perftools-1.7.orig/src/google/malloc_hook_c.h
-+++ google-perftools-1.7/src/google/malloc_hook_c.h
-@@ -40,7 +40,7 @@
- #include <stddef.h>
- #include <sys/types.h>
-
--// Annoying stuff for windows -- makes sure clients can import these functions
-+/* Annoying stuff for windows -- makes sure clients can import these functions */
- #ifndef PERFTOOLS_DLL_DECL
- # ifdef _WIN32
- # define PERFTOOLS_DLL_DECL __declspec(dllimport)
diff --git a/dev-util/google-perftools/google-perftools-1.6.ebuild b/dev-util/google-perftools/google-perftools-1.10.ebuild
index 81ecedfba82a..8d102c4ba6a7 100644
--- a/dev-util/google-perftools/google-perftools-1.6.ebuild
+++ b/dev-util/google-perftools/google-perftools-1.10.ebuild
@@ -1,27 +1,23 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-1.6.ebuild,v 1.4 2012/06/07 21:32:04 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-1.10.ebuild,v 1.1 2012/07/06 00:57:34 flameeyes Exp $
-EAPI=2
+EAPI=4
-inherit flag-o-matic toolchain-funcs
+inherit toolchain-funcs eutils flag-o-matic
DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
-HOMEPAGE="http://code.google.com/p/google-perftools/"
-SRC_URI="http://google-perftools.googlecode.com/files/${P}.tar.gz"
+HOMEPAGE="http://code.google.com/p/gperftools/"
+SRC_URI="http://gperftools.googlecode.com/files/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="largepages +debug minimal" # test"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="largepages +debug minimal test"
DEPEND="sys-libs/libunwind"
RDEPEND="${DEPEND}"
-# tests get stuck in a deadlock due to sandbox interactions.
-# bug #290249.
-RESTRICT=test
-
pkg_setup() {
# set up the make options in here so that we can actually make use
# of them on both compile and install.
@@ -30,8 +26,7 @@ pkg_setup() {
# tests; this trick here allows us to ignore the tests without
# touching the build system (and thus without rebuilding
# autotools). Keep commented as long as it's restricted.
-
- # use test && \
+ use test || \
makeopts="${makeopts} noinst_PROGRAMS= "
# don't install _anything_ from the documentation, since it would
@@ -42,6 +37,8 @@ pkg_setup() {
src_configure() {
use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
+ append-flags -fno-strict-aliasing
+
econf \
--disable-static \
--disable-dependency-tracking \
@@ -51,17 +48,29 @@ src_configure() {
}
src_compile() {
- emake ${makeopts} || die "emake failed"
+ emake ${makeopts}
+}
+
+src_test() {
+ case "${LD_PRELOAD}" in
+ *libsandbox*)
+ ewarn "Unable to run tests when sanbox is enabled."
+ ewarn "See http://bugs.gentoo.org/290249"
+ return 0
+ ;;
+ esac
+
+ emake check
}
src_install() {
- emake DESTDIR="${D}" install ${makeopts} || die "emake install failed"
+ emake DESTDIR="${D}" install ${makeopts}
# Remove libtool files since we dropped the static libraries
find "${D}" -name '*.la' -delete
- dodoc README AUTHORS ChangeLog TODO NEWS || die
+ dodoc README AUTHORS ChangeLog TODO NEWS
pushd doc
- dohtml -r * || die
+ dohtml -r *
popd
}
diff --git a/dev-util/google-perftools/google-perftools-1.7.ebuild b/dev-util/google-perftools/google-perftools-2.0.ebuild
index 4225079fac7b..8b17ece415ef 100644
--- a/dev-util/google-perftools/google-perftools-1.7.ebuild
+++ b/dev-util/google-perftools/google-perftools-2.0.ebuild
@@ -1,25 +1,26 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-1.7.ebuild,v 1.1 2011/03/06 12:50:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-2.0.ebuild,v 1.1 2012/07/06 00:57:34 flameeyes Exp $
-EAPI=2
+EAPI=4
+
+MY_P="gperftools-${PV}"
inherit toolchain-funcs eutils flag-o-matic
DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
-HOMEPAGE="http://code.google.com/p/google-perftools/"
-SRC_URI="http://google-perftools.googlecode.com/files/${P}.tar.gz"
+HOMEPAGE="http://code.google.com/p/gperftools/"
+SRC_URI="http://gperftools.googlecode.com/files/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="largepages +debug minimal" # test"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="largepages +debug minimal test"
DEPEND="sys-libs/libunwind"
RDEPEND="${DEPEND}"
-# tests end up in an infinite loop, even without sandbox
-RESTRICT=test
+S="${WORKDIR}/${MY_P}"
pkg_setup() {
# set up the make options in here so that we can actually make use
@@ -29,8 +30,7 @@ pkg_setup() {
# tests; this trick here allows us to ignore the tests without
# touching the build system (and thus without rebuilding
# autotools). Keep commented as long as it's restricted.
-
- # use test && \
+ use test || \
makeopts="${makeopts} noinst_PROGRAMS= "
# don't install _anything_ from the documentation, since it would
@@ -38,10 +38,6 @@ pkg_setup() {
makeopts="${makeopts} dist_doc_DATA= "
}
-src_prepare() {
- epatch "${FILESDIR}/${P}-syntax.patch"
-}
-
src_configure() {
use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
@@ -56,7 +52,7 @@ src_configure() {
}
src_compile() {
- emake ${makeopts} || die "emake failed"
+ emake ${makeopts}
}
src_test() {
@@ -68,17 +64,17 @@ src_test() {
;;
esac
- emake check || die "tests failed"
+ emake check
}
src_install() {
- emake DESTDIR="${D}" install ${makeopts} || die "emake install failed"
+ emake DESTDIR="${D}" install ${makeopts}
# Remove libtool files since we dropped the static libraries
find "${D}" -name '*.la' -delete
- dodoc README AUTHORS ChangeLog TODO NEWS || die
+ dodoc README AUTHORS ChangeLog TODO NEWS
pushd doc
- dohtml -r * || die
+ dohtml -r *
popd
}