summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgconf/ChangeLog7
-rw-r--r--dev-util/pkgconf/pkgconf-0.8.12.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-util/pkgconf/ChangeLog b/dev-util/pkgconf/ChangeLog
index 21594ef79634..76877c18f382 100644
--- a/dev-util/pkgconf/ChangeLog
+++ b/dev-util/pkgconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/pkgconf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.65 2013/02/24 16:14:18 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.66 2013/02/26 02:19:05 jdhore Exp $
+
+*pkgconf-0.8.12 (26 Feb 2013)
+
+ 26 Feb 2013; Jeff Horelick <jdhore@gentoo.org> +pkgconf-0.8.12.ebuild:
+ Version bump. Fixes bug #459108
*pkgconf-0.8.11 (24 Feb 2013)
diff --git a/dev-util/pkgconf/pkgconf-0.8.12.ebuild b/dev-util/pkgconf/pkgconf-0.8.12.ebuild
new file mode 100644
index 000000000000..1aab3a189ab4
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-0.8.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-0.8.12.ebuild,v 1.1 2013/02/26 02:19:05 jdhore Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/pkgconf/pkgconf.git"
+ inherit autotools git-2
+else
+ inherit eutils
+ SRC_URI="http://tortois.es/~nenolod/distfiles/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/pkgconf/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+pkg-config strict"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )"
+
+src_prepare() {
+ [[ -e configure ]] || eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable strict)
+}
+
+src_install() {
+ default
+ use pkg-config \
+ && dosym pkgconf /usr/bin/pkg-config \
+ || rm "${ED}"/usr/share/aclocal/pkg.m4 \
+ || die
+}