summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/yacc')
-rw-r--r--dev-util/yacc/files/digest1
-rw-r--r--dev-util/yacc/yacc-1.9.1-r1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/yacc/files/digest b/dev-util/yacc/files/digest
new file mode 100644
index 000000000000..0fbb5ecdd357
--- /dev/null
+++ b/dev-util/yacc/files/digest
@@ -0,0 +1 @@
+MD5 3bcf50bece4ef1d0fbaf479e25790437 yacc-1.9.1.tar.Z
diff --git a/dev-util/yacc/yacc-1.9.1-r1.ebuild b/dev-util/yacc/yacc-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..d26f4c632f5e
--- /dev/null
+++ b/dev-util/yacc/yacc-1.9.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/yacc/yacc-1.9.1-r1.ebuild,v 1.1 2000/08/13 12:10:49 achim Exp $
+
+P=yacc-1.9.1
+A=${P}.tar.Z
+S=${WORKDIR}/${P}
+CATEGORY="dev-util"
+DESCRIPTION="Yacc"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/devel/compiler-tools/${A}"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-O:${CFLAGS}:" Makefile.orig > Makefile
+}
+src_compile() {
+ make clean
+ make
+}
+
+src_install() {
+ into /usr
+ dobin yacc
+ doman yacc.1
+ dodoc 00README* ACKNOWLEDGEMENTS NEW_FEATURES NO_WARRANTY NOTES README*
+ ln -s /usr/lib/cvs/contrib ${D}/usr/doc/${P}/contrib
+}
+
+
+
+