summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/xdelta/xdelta-3.0v.ebuild')
-rw-r--r--dev-util/xdelta/xdelta-3.0v.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/xdelta/xdelta-3.0v.ebuild b/dev-util/xdelta/xdelta-3.0v.ebuild
new file mode 100644
index 000000000000..dbc40b2a590e
--- /dev/null
+++ b/dev-util/xdelta/xdelta-3.0v.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xdelta/xdelta-3.0v.ebuild,v 1.1 2009/06/28 17:49:40 patrick Exp $
+
+inherit distutils
+
+# there was a 3.0v2 release
+MY_P=${PN}${PV}2
+
+DESCRIPTION="a binary diff and differential compression tools. VCDIFF (RFC 3284) delta compression."
+HOMEPAGE="http://xdelta.org"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/python"
+DEPEND="${RDEPEND}"
+
+# but the v2 doesn't show in the tarball. sigh!
+S=${WORKDIR}/${PN}${PV}
+
+DOCS="draft-korn-vcdiff.txt"
+
+# made redundant
+#pkg_setup() {
+# if use alpha || use amd64 || use ia64 || use ppc64 || use sparc; then
+# xdelta="xdelta3-64"
+# else
+# xdelta="xdelta3"
+# fi
+#}
+
+src_compile() {
+ distutils_src_compile
+ emake all || die "emake all failed."
+}
+
+src_install() {
+ dobin xdelta3 || die "dobin xdelta failed."
+ distutils_src_install
+}