summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/uncrustify/uncrustify-0.53.ebuild')
-rw-r--r--dev-util/uncrustify/uncrustify-0.53.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/uncrustify/uncrustify-0.53.ebuild b/dev-util/uncrustify/uncrustify-0.53.ebuild
new file mode 100644
index 000000000000..6bbe6506c799
--- /dev/null
+++ b/dev-util/uncrustify/uncrustify-0.53.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/uncrustify/uncrustify-0.53.ebuild,v 1.1 2009/10/04 15:19:01 sping Exp $
+
+DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
+HOMEPAGE="http://uncrustify.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+DEPEND="test? ( dev-lang/python )"
+RDEPEND=""
+
+src_test() {
+ cd tests
+ ./run_tests.py || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS BUGS NEWS README || die "dodoc failed"
+}