summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rootstrap/rootstrap-0.3.18.ebuild')
-rw-r--r--dev-util/rootstrap/rootstrap-0.3.18.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/rootstrap/rootstrap-0.3.18.ebuild b/dev-util/rootstrap/rootstrap-0.3.18.ebuild
new file mode 100644
index 000000000000..6364f2a11a77
--- /dev/null
+++ b/dev-util/rootstrap/rootstrap-0.3.18.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rootstrap/rootstrap-0.3.18.ebuild,v 1.1 2004/03/02 13:58:51 lanius Exp $
+
+DESCRIPTION="A tool for building complete Linux filesystem images"
+HOMEPAGE="http://packages.qa.debian.org/rootstrap"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SRC_URI="mirror://debian/pool/main/r/rootstrap/rootstrap_${PV}.orig.tar.gz
+ mirror://debian/pool/main/r/rootstrap/rootstrap_${PV}-1.diff.gz"
+
+S=${WORKDIR}/rootstrap-${PV}.orig
+
+DEPEND="sys-kernel/usermode-sources
+ dev-util/debootstrap
+ app-arch/dpkg
+ dev-lang/python
+ app-text/docbook-sgml-utils"
+IUSE=""
+
+src_unpack() {
+ unpack rootstrap_${PV}.orig.tar.gz
+ epatch ${DISTDIR}/rootstrap_${PV}-1.diff.gz
+ cd ${S}
+ sed -i -e "s/docbook-to-man/docbook2man/" Makefile
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ dodoc COPYING
+}