summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120116.ebuild')
-rw-r--r--dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120116.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120116.ebuild b/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120116.ebuild
index 611e7c65211a..3491b1ecb461 100644
--- a/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120116.ebuild
+++ b/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120116.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120116.ebuild,v 1.1 2012/01/16 22:15:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120116.ebuild,v 1.2 2012/01/17 00:43:04 ssuominen Exp $
# cvs -d anoncvs@anoncvs.openbsd.org:/cvs get src/usr.bin/pkg-config/pkg-config
# cvs -d anoncvs@anoncvs.openbsd.org:/cvs get src/usr.bin/pkg-config/pkg-config.1
@@ -22,6 +22,11 @@ DEPEND=""
S=${WORKDIR}/src
+src_prepare() {
+ # Config.pm from dev-lang/perl doesn't set ARCH, only archname
+ sed -i -e '/Config/s:ARCH:archname:' usr.bin/pkg-config/pkg-config || die
+}
+
src_install() {
newbin usr.bin/pkg-config/pkg-config pkg-config-openbsd
newman usr.bin/pkg-config/pkg-config.1 pkg-config-openbsd.1