summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/jif/jif-3_rc1.ebuild')
-rw-r--r--dev-util/jif/jif-3_rc1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/jif/jif-3_rc1.ebuild b/dev-util/jif/jif-3_rc1.ebuild
new file mode 100644
index 000000000000..c6a744be5c4e
--- /dev/null
+++ b/dev-util/jif/jif-3_rc1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/jif/jif-3_rc1.ebuild,v 1.1 2006/01/26 14:39:17 s4t4n Exp $
+
+inherit java-pkg
+
+MY_PN=${PN/jif/JIF}
+MY_PV=${PV/rc/RC}
+MY_PV_MAJOR=${MY_PV/_*/}
+MY_PV_MINOR=${MY_PV/*_/}
+MY_P=${MY_PN}${MY_PV_MAJOR}_src_${MY_PV_MINOR}
+
+IUSE=""
+
+DESCRIPTION="JIF is an IDE for the creation of text adventures based on Graham Nelson's Inform standard."
+HOMEPAGE="http://www.slade.altervista.org/JIF/"
+SRC_URI="http://www.slade.altervista.org/JIF/download/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=virtual/jdk-1.4
+ >=sys-apps/sed-4.1.4"
+
+RDEPEND=">=virtual/jre-1.4
+ >=dev-lang/inform-6.21.4
+ >=games-engines/gargoyle-20051002"
+
+S=${WORKDIR}/src
+
+src_compile()
+{
+ # Compile classes just as it is done upstream
+ javac -source 1.4 -O -classpath . *.java
+
+ # Adapt default Jif.cfg file to Gentoo
+ sed -i -e "s:\[EXECUTE\]e\,explorer.exe:#\[EXECUTE\]e\,explorer.exe:" Jif.cfg
+ sed -i -e "s:\[EXECUTE\]d\,hh.exe\ C\:\\\Jif\\\doc\\\prova.chm:#\[EXECUTE\]d\,hh.exe\ C\:\\\Jif\\\doc\\\prova.chm:" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Lib\\\Base:/usr/share/inform/6.21/module:" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Lib\\\Contrib::" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Games::" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Bin\\\interpreter\\\Frotz\\\Frotz.exe:/usr/bin/frotz:" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Bin\\\interpreter\\\Gargoyle\\\Gargoyle.exe:/usr/bin/gargoyle:" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Bin\\\compiler\\\inform.exe:/usr/bin/inform:" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Bin\\\tools\\\Blorb\\\bres.exe::" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Bin\\\tools\\\Blorb\\\blc.exe::" Jif.cfg
+ sed -i -e "s:Italian,on:Italian,off:" Jif.cfg
+ sed -i -e "s:English,off:English,on:" Jif.cfg
+
+ # Pack them as upstream
+ jar cvfm Jif.jar MANIFEST.MF *.class *.properties images/*.png readme.txt Jif.cfg
+}
+
+src_install()
+{
+ java-pkg_dojar Jif.jar
+ dobin ${FILESDIR}/jif
+ dodoc CHANGELOG.txt readme.txt
+}