summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/eric/eric-3.8.1.ebuild')
-rw-r--r--dev-util/eric/eric-3.8.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/eric/eric-3.8.1.ebuild b/dev-util/eric/eric-3.8.1.ebuild
new file mode 100644
index 000000000000..1704be449166
--- /dev/null
+++ b/dev-util/eric/eric-3.8.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-3.8.1.ebuild,v 1.1 2005/12/31 02:06:11 carlo Exp $
+
+inherit python eutils
+
+MY_PV=${PV/"?.?_pre"/"snapshot-"}
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DESCRIPTION="eric3 is a full featured Python IDE that is written in PyQt using the QScintilla editor widget"
+HOMEPAGE="http://www.die-offenbachs.de/detlev/eric3.html"
+SRC_URI="mirror://sourceforge/eric-ide/${P}.tar.gz
+ linguas_de? ( mirror://sourceforge/eric-ide/${PN}-i18n-de-${PV}.tar.gz )
+ linguas_fr? ( mirror://sourceforge/eric-ide/${PN}-i18n-fr-${PV}.tar.gz )
+ linguas_ru? ( mirror://sourceforge/eric-ide/${PN}-i18n-ru-${PV}.tar.gz )"
+#SRC_URI="http://www.die-offenbachs.de/detlev/snapshots/${PN}-${MY_PV}.tar.gz
+# linguas_de? ( http://www.die-offenbachs.de/detlev/snapshots/${PN}-i18n-de-${MY_PV}.tar.gz )
+# linguas_fr? ( http://www.die-offenbachs.de/detlev/snapshots/${PN}-i18n-fr-${MY_PV}.tar.gz )
+# linguas_ru? ( http://www.die-offenbachs.de/detlev/snapshots/${PN}-i18n-ru-${MY_PV}.tar.gz )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="idl"
+
+DEPEND=">=dev-python/PyQt-3.13
+ >=dev-python/pyxml-0.8.4"
+
+RDEPEND=">=dev-python/PyQt-3.13
+ >=dev-python/pyxml-0.8.4
+ idl? ( !sparc? ( >=net-misc/omniORB-4.0.3 ) )"
+
+LANGS="de fr ru"
+
+python_version
+
+src_install() {
+ python install.py \
+ -b ${ROOT}usr/bin \
+ -i ${D} \
+ -d "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages" \
+ -c
+
+ dodoc HISTORY LICENSE.GPL THANKS eric/README*
+ make_desktop_entry "eric3 --nosplash" \
+ eric3 \
+ "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/icons/default/eric.png" \
+ "Development;IDE;Qt"
+}
+
+pkg_postinst() {
+ echo ""
+ einfo "If you want to use eric3 with mod_python, have a look at"
+ einfo "\"${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/eric3/patch_modpython.py\"."
+ echo ""
+} \ No newline at end of file