summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cppi/cppi-1.16.ebuild')
-rw-r--r--dev-util/cppi/cppi-1.16.ebuild19
1 files changed, 16 insertions, 3 deletions
diff --git a/dev-util/cppi/cppi-1.16.ebuild b/dev-util/cppi/cppi-1.16.ebuild
index 8a24f45bac44..1e46e21779e0 100644
--- a/dev-util/cppi/cppi-1.16.ebuild
+++ b/dev-util/cppi/cppi-1.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppi/cppi-1.16.ebuild,v 1.2 2012/01/26 06:27:40 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppi/cppi-1.16.ebuild,v 1.3 2012/01/26 06:42:55 jer Exp $
EAPI=4
@@ -11,8 +11,21 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="nls"
-DEPEND="app-arch/xz-utils"
+CPPI_LINGUAS="sv eo fi vi it uk sr fr ja pl"
+
+for lingua in ${CPPI_LINGUAS}; do
+ IUSE+=" linguas_${lingua}"
+done
+
+DEPEND="
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )
+"
DOCS=( AUTHORS ChangeLog NEWS THANKS TODO )
+
+src_configure() {
+ econf $(use_enable nls)
+}