summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/tth/tth-3.77.ebuild')
-rw-r--r--dev-tex/tth/tth-3.77.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-tex/tth/tth-3.77.ebuild b/dev-tex/tth/tth-3.77.ebuild
index bf91a28de4fd..1f51b23a723b 100644
--- a/dev-tex/tth/tth-3.77.ebuild
+++ b/dev-tex/tth/tth-3.77.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/tth/tth-3.77.ebuild,v 1.6 2011/02/12 17:28:02 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/tth/tth-3.77.ebuild,v 1.7 2012/01/10 19:39:06 jlec Exp $
+
+EAPI=4
inherit toolchain-funcs
-DESCRIPTION="TTH translates TEX into HTML."
+DESCRIPTION="Translate TEX into HTML"
HOMEPAGE="http://hutchinson.belmont.ma.us/tth/"
SRC_URI="mirror://gentoo/${P}.tgz"
@@ -14,7 +16,8 @@ KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
IUSE=""
DEPEND=""
-RDEPEND="app-text/ghostscript-gpl
+RDEPEND="
+ app-text/ghostscript-gpl
media-libs/netpbm"
S="${WORKDIR}/tth_C"
@@ -22,11 +25,11 @@ S="${WORKDIR}/tth_C"
src_compile() {
echo 'all: tth' > Makefile
tc-export CC
- emake || die "compile failed"
+ emake
}
src_install() {
- dobin tth latex2gif ps2gif ps2png || die
+ dobin tth latex2gif ps2gif ps2png
dodoc CHANGES
doman tth.1
dohtml *