summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/gem_plugin/ChangeLog7
-rw-r--r--dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild6
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-ruby/gem_plugin/ChangeLog b/dev-ruby/gem_plugin/ChangeLog
index 37008e5e7e27..eb67da3ee1f4 100644
--- a/dev-ruby/gem_plugin/ChangeLog
+++ b/dev-ruby/gem_plugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/gem_plugin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gem_plugin/ChangeLog,v 1.20 2010/01/05 19:41:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gem_plugin/ChangeLog,v 1.21 2010/01/23 23:08:14 flameeyes Exp $
+
+ 23 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ gem_plugin-0.2.3-r1.ebuild:
+ Fix tests to run without gem_plugin installed, properly die on failure,
+ and add ruby19/jruby support.
*gem_plugin-0.2.3-r1 (05 Jan 2010)
diff --git a/dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild b/dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild
index c815bec53fb1..113fffb396df 100644
--- a/dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild
+++ b/dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild,v 1.1 2010/01/05 19:41:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gem_plugin/gem_plugin-0.2.3-r1.ebuild,v 1.2 2010/01/23 23:08:14 flameeyes Exp $
EAPI="2"
-USE_RUBY="ruby18"
+USE_RUBY="ruby18 ruby19 jruby"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_TASK_TEST=""
@@ -24,5 +24,5 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-
IUSE=""
each_fakegem_test() {
- ${RUBY} test/test_plugins.rb
+ ${RUBY} -Ilib test/test_plugins.rb || die "tests failed"
}