summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/test_declarative/test_declarative-0.0.5-r1.ebuild')
-rw-r--r--dev-ruby/test_declarative/test_declarative-0.0.5-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/test_declarative/test_declarative-0.0.5-r1.ebuild b/dev-ruby/test_declarative/test_declarative-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..d7cf11a78e2a
--- /dev/null
+++ b/dev-ruby/test_declarative/test_declarative-0.0.5-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test_declarative/test_declarative-0.0.5-r1.ebuild,v 1.1 2012/07/26 17:47:57 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 jruby ruby19 rbx"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.textile"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simply adds a declarative test method syntax to test/unit."
+HOMEPAGE="https://github.com/svenfuchs/test_declarative"
+SRC_URI="https://github.com/svenfuchs/test_declarative/tarball/v${PV} -> ${P}.tgz"
+RUBY_S="svenfuchs-test_declarative-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} test/test_declarative_test.rb || die "Tests failed."
+}