summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec/rspec-1.2.9-r1.ebuild')
-rw-r--r--dev-ruby/rspec/rspec-1.2.9-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/rspec/rspec-1.2.9-r1.ebuild b/dev-ruby/rspec/rspec-1.2.9-r1.ebuild
new file mode 100644
index 000000000000..9955bc1e431d
--- /dev/null
+++ b/dev-ruby/rspec/rspec-1.2.9-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.2.9-r1.ebuild,v 1.1 2009/12/15 15:06:29 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+RESTRICT=test
+
+all_ruby_install() {
+ for bin in spec autospec; do
+ ruby_fakegem_binwrapper $bin
+ done
+
+ dodoc History.rdoc README.rdoc TODO.txt Ruby1.9.rdoc Upgrade.rdoc || die
+}