summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pg')
-rw-r--r--dev-ruby/pg/ChangeLog7
-rw-r--r--dev-ruby/pg/pg-0.9.0-r1.ebuild13
2 files changed, 16 insertions, 4 deletions
diff --git a/dev-ruby/pg/ChangeLog b/dev-ruby/pg/ChangeLog
index 0ba0839e4eda..74e4bd66456c 100644
--- a/dev-ruby/pg/ChangeLog
+++ b/dev-ruby/pg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/pg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.13 2010/04/27 10:24:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.14 2010/05/01 11:13:10 flameeyes Exp $
+
+ 01 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> pg-0.9.0-r1.ebuild:
+ Make testing explicit with RSpec rather than using the Rakefile, this way
+ it does not rebuild the extension when tests are enabled, and reduced the
+ dependency tree.
*pg-0.9.0-r1 (27 Apr 2010)
diff --git a/dev-ruby/pg/pg-0.9.0-r1.ebuild b/dev-ruby/pg/pg-0.9.0-r1.ebuild
index 1e74855dd3d2..c56db715dfbd 100644
--- a/dev-ruby/pg/pg-0.9.0-r1.ebuild
+++ b/dev-ruby/pg/pg-0.9.0-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.9.0-r1.ebuild,v 1.1 2010/04/27 10:24:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.9.0-r1.ebuild,v 1.2 2010/05/01 11:13:10 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18 ruby19"
-RUBY_FAKEGEM_TEST_TASK="spec"
+RUBY_FAKEGEM_TEST_TASK=""
RUBY_FAKEGEM_TASK_DOC="rdoc"
RUBY_FAKEGEM_DOCDIR="docs/api"
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}
# package; what is shipped with Ruby 1.9 is not good enough as it
# lacks the packaging tasks for Rake.
ruby_add_bdepend doc "dev-ruby/rake-compiler dev-ruby/rubygems"
-ruby_add_bdepend test "dev-ruby/rspec dev-ruby/rake-compiler dev-ruby/rubygems"
+ruby_add_bdepend test dev-ruby/rspec
each_ruby_configure() {
pushd ext
@@ -44,3 +44,10 @@ each_ruby_compile() {
popd
cp ext/*.so lib || die
}
+
+each_ruby_test() {
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ ${RUBY} -Ilib -S spec -Du -fs spec/*_spec.rb || die "spec failed"
+}