summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/kramdown')
-rw-r--r--dev-ruby/kramdown/ChangeLog5
-rw-r--r--dev-ruby/kramdown/kramdown-0.14.2.ebuild44
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/kramdown/ChangeLog b/dev-ruby/kramdown/ChangeLog
index 6eb7b58b1b7d..7ae25074dc3d 100644
--- a/dev-ruby/kramdown/ChangeLog
+++ b/dev-ruby/kramdown/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/kramdown
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/ChangeLog,v 1.28 2013/10/04 12:51:36 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/ChangeLog,v 1.29 2013/10/05 08:42:41 graaff Exp $
+
+ 05 Oct 2013; Hans de Graaff <graaff@gentoo.org> +kramdown-0.14.2.ebuild:
+ Add back a version that still has jruby in USE_RUBY, fixing bug 486986.
04 Oct 2013; Manuel Rüger <mrueg@gentoo.org> -kramdown-0.14.2.ebuild,
-kramdown-1.0.2.ebuild:
diff --git a/dev-ruby/kramdown/kramdown-0.14.2.ebuild b/dev-ruby/kramdown/kramdown-0.14.2.ebuild
new file mode 100644
index 000000000000..7fcf2aaba6a0
--- /dev/null
+++ b/dev-ruby/kramdown/kramdown-0.14.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/kramdown-0.14.2.ebuild,v 1.3 2013/10/05 08:42:41 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="htmldoc/rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS ChangeLog CONTRIBUTERS"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="yet-another-markdown-parser but fast, pure Ruby, using a strict syntax definition."
+HOMEPAGE="http://kramdown.rubyforge.org/"
+
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="latex"
+
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND+=" ${LATEX_DEPS}"
+DEPEND+=" test? ( ${LATEX_DEPS} app-text/htmltidy )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( >=dev-ruby/coderay-1.0.0 )"
+
+all_ruby_prepare() {
+ if ! use latex; then
+ # Remove latex tests. They will fail gracefully when latex isn't
+ # present at all, but not when components are missing (most
+ # notable ucs.sty).
+ sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
+ fi
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/kramdown.1
+}