summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/dnsruby/dnsruby-1.55.ebuild')
-rw-r--r--dev-ruby/dnsruby/dnsruby-1.55.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/dnsruby/dnsruby-1.55.ebuild b/dev-ruby/dnsruby/dnsruby-1.55.ebuild
new file mode 100644
index 000000000000..4048d143b758
--- /dev/null
+++ b/dev-ruby/dnsruby/dnsruby-1.55.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/dnsruby/dnsruby-1.55.ebuild,v 1.1 2014/10/11 06:47:41 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC="DNSSEC EXAMPLES README"
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby DNS client library"
+HOMEPAGE="http://rubyforge.org/projects/dnsruby"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ # only run offline tests
+ #${RUBY} -I .:lib test/ts_dnsruby.rb || die "test failed"
+ ${RUBY} -I .:lib test/ts_offline.rb || die "test failed"
+}