summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/dbd-pg')
-rw-r--r--dev-ruby/dbd-pg/ChangeLog9
-rw-r--r--dev-ruby/dbd-pg/dbd-pg-0.3.9.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-ruby/dbd-pg/ChangeLog b/dev-ruby/dbd-pg/ChangeLog
index 6e500dbca7ac..a9cf29fabec2 100644
--- a/dev-ruby/dbd-pg/ChangeLog
+++ b/dev-ruby/dbd-pg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/dbd-pg
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/dbd-pg/ChangeLog,v 1.4 2009/12/20 12:42:03 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/dbd-pg/ChangeLog,v 1.5 2010/06/20 18:04:21 graaff Exp $
+
+*dbd-pg-0.3.9 (20 Jun 2010)
+
+ 20 Jun 2010; Hans de Graaff <graaff@gentoo.org> +dbd-pg-0.3.9.ebuild:
+ Version bump. Convert to ruby-ng.
20 Dec 2009; Hans de Graaff <graaff@gentoo.org> dbd-pg-0.3.8.ebuild:
Remove obsolete virtual/ruby dependency.
diff --git a/dev-ruby/dbd-pg/dbd-pg-0.3.9.ebuild b/dev-ruby/dbd-pg/dbd-pg-0.3.9.ebuild
new file mode 100644
index 000000000000..ee0f167ec1b2
--- /dev/null
+++ b/dev-ruby/dbd-pg/dbd-pg-0.3.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/dbd-pg/dbd-pg-0.3.9.ebuild,v 1.1 2010/06/20 18:04:21 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+DESCRIPTION="The PostgreSQL database driver (DBD) for Ruby/DBI"
+HOMEPAGE="http://ruby-dbi.rubyforge.org"
+SRC_URI="mirror://rubyforge/ruby-dbi/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/ruby-dbi-0.4.2
+ >=dev-ruby/ruby-postgres-0.7.9.20080128"
+
+src_test() {
+ elog "The tests require additional configuration."
+ elog "You will find them in /usr/share/${PN}/test/"
+ elog "Be sure to read the file called DBD_TESTS."
+}
+
+each_ruby_configure() {
+ ${RUBY} setup.rb config --prefix=/usr || die
+}
+
+each_ruby_install() {
+ ${RUBY} setup.rb install --prefix="${D}" || die "setup.rb install failed"
+}
+
+all_ruby_install() {
+ if use test; then
+ dodir /usr/share/${PN}
+ cp -pPR test "${D}/usr/share/${PN}" || die "couldn't copy tests"
+ fi
+}